Closed Bug 491859 Opened 11 years ago Closed 11 years ago

Content of tabs isn't drawn anymore in Mozmill after opening any test and clicking another tab

Categories

(Core :: Layout, defect, major)

defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: whimboo, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Blank Mozmill tabs
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090507 Minefield/3.6a1pre ID:20090507032833

Since the interruptible reflow patch has been landed on trunk (http://hg.mozilla.org/mozilla-central/rev/a08d1947ec5a) parts of the UI in Mozmill aren't drawn anymore and stay blank. The Mozmill window has to be resized to fix this problem until the next time the user switches the tab.

Steps:
1. Create a fresh profile and install the latest Mozmill trunk build. I'll attach one build from r456.
2. Press Cmd+O and select any local js file
3. Click on the output tab
4. Click on the editor tab
5. Resize the window

With step 4 the editor tab is blank. There is nothing shown anymore. Same applies to all the other tabs. With step 5 the content is visible again. I will attach a screenshot.
It's better when a real mozmill test is used for testing. You can clone the mozmill-test repository (http://hg.mozilla.org/qa/mozmill-tests) and use firefox/testBookmarks/testAddBookmarkToMenu.js.

This behavior is also visible on Windows.
OS: Mac OS X → All
Hardware: x86 → All
I can't repro this with trunk, or the provided extension on mac or windows.
Just to double-check, is this still an issue?  I fixed a number of bad regressions from bug 67752 a few days back, and depending on what exact CSS mozmill is using those fixes might well have fixed it...
Oh, and the steps in comment 0 seem to be missing "Go to the tools menu and open mozmill, then do the rest of the steps in that window" between step 1 and step 2.

With that added in, this bug wfm (and even does that if I locally back out the fix that would have been most likely to fix such a problem).

I didn't use the file from comment 2, though; I used an existing 19-line JS file I had lying about.
Thanks Boris. I checked again and I cannot reproduce it anymore. Seems like one of your fixes have been fixed this bug. Marking as WFM.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.