Closed Bug 491865 Opened 13 years ago Closed 12 years ago

about:firstrun is too wide in portrait mode

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Windows Mobile 6 Professional
defect
Not set
major

Tracking

(fennec1.0b1-wm+)

VERIFIED FIXED
Tracking Status
fennec 1.0b1-wm+ ---

People

(Reporter: dougt, Unassigned)

References

Details

(Whiteboard: [fennec l10n])

when loading fennec the first time, the about:first run extends beyond the border of the screen.  We probably need an image that works in portrait mode.
Blocks: 477628
tracking-fennec: --- → ?
From an l10n point of view, the text on the splash screen should be localizable.

A single image might not cut it, I don't have a much better idea ad-hoc though. Pascal has more experience with the wideness etc.

Current image is at http://mxr.mozilla.org/mobile-browser/source/themes/wince/firstrun/firstrun_splash.gif.
Whiteboard: [fennec l10n]
The same behavior (extension beyond the border of the screen) occurs on the Omnia in landscape mode as well.
Regarding the text in image, I see two possible options:
- shipping Fennec with a different localized splash image per locale.
- having about:firstrun a simple html page with real text stored in the app

If you have a localized image, this implies graphics work from your designer to create these graphics.

If you have real text, it implies some positionning work of the text and it will probably not look exactly as you wish (looks like the image is using the Meta Bold commercial font, we would have to use a more commonly available font on Windows Mobile). As a general rule, you should keep 30% space around your text so as to leave room for languages using more letters than English.
tracking-fennec: ? → 1.0b1-wm+
this was fixed with tile cache and out patches to support portrait mode
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Blassey, this is not a works for me as the bug was filed BEFORE the patches were added to trunk and 1.9.2 branch.  Please add the bug ID's to this bug and set it to verified.

I'm moving this to resolved:fixed as the issue is fixed on builds:


Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2a2pre) Gecko/20090909
Fennec/1.0a3

and

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.3a1pre) Gecko/20090909
Fennec/1.0a3

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.2a2pre) Gecko/20090909
Fennec/1.0b4pre
Resolution: WORKSFORME → FIXED
VERIFIED FIXED on:

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110524 Firefox/6.0a1 Fennec/6.0a1 

Device: HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.