Closed Bug 491982 Opened 11 years ago Closed 11 years ago

Firefox sends (!) application/x-forcedownload when uploading a file to a form with enctype="multipart/form-data"

Categories

(Firefox :: File Handling, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 373621

People

(Reporter: michael+moz, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.7) Gecko/2009030810 Iceweasel/3.0.9 (Debian-3.0.9-1)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.7) Gecko/2009030810 Iceweasel/3.0.9 (Debian-3.0.9-1)

See below.

Reproducible: Always

Steps to Reproduce:
1. Create a PHP script like this: <?php print_r($_FILES); ?><form enctype="multipart/form-data" action="index.php" method="post"><input type="file" name="pdfname">
2. Upload a PDF file with name Loesung.pdf (probably irrelevant)
3. Use tcpdump if you want to see that firefox is actually sending this and it’s not a server-side problem.
Actual Results:  
Firefox sends Content-Type: application/x-forcedata

Expected Results:  
Firefox should send application/pdf as it is listed in /etc/mime.types
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373621
You need to log in before you can comment on or make changes to this bug.