After Tooltip appearance, next mouse move causes false trigger of onmouseout event for parent element.

RESOLVED DUPLICATE of bug 443178

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 443178
9 years ago
9 years ago

People

(Reporter: Nathan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10

Everything is explained in the testbed HTML file contained in the zip file at:

http://sites.google.com/site/madewithblender/file-cabinet/TestCase.html.zip

But basically, if you have a tooltip on an element, and the tooltip appears, the next time you move the mouse it triggers an onmouseout event for the parent element.  The coords on the event are bugged, reporting the mouse at a position nowhere near where it really is.  This behaviour messes up dynamic menus with tooltips in them, causing the menu to close just because a tooltip appeared.

Reproducible: Always

Steps to Reproduce:
1.  Open the HTML testbed at http://sites.google.com/site/madewithblender/file-cabinet/TestCase.html.zip
2.  Mouse over the <div> at the top.
3.  When the popup menu appears, mouse over the image and wait for the tooltip to appear.
4.  When the tooltip appears move the mouse pointer one pixel in any direction.
Actual Results:  
An onmouseout event is triggered for the parent element despite the fact that the mouse never moved out of the parent, nor even out of the image it was over when the tooltip appeared.

The mouse coords associated with the event are incorrect as well, showing the mouse at a location where it is not.

Expected Results:  
The onmouseout event should not have been triggered.

This bug is messing up the popup menu in my website, rendering it fairly useless in Firefox, so I would appreciate it if it was fixed a quickly as reasonably possible.
I believe I can't reproduce the issue on Windows XP with Firefox 3. When I move my mouse a few pixels I still see the tooltip (as long as it doesn't time out).
The tooltip behavior has been changed recently, can you test with the latest trunk build to see if you still can reproduce it? 
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
(Reporter)

Comment 2

9 years ago
I justed tested it on the latest nightly build with all addons disabled on Mac OS X and it still has the bug.

If you are correct, and it doesn't effect Windows XP users, then that takes a big load off my mind.  It means that the bug is probably just affecting the 1%-2% that use Mac OS X on my site, rather than the 50% that use Firefox!

However, I would still like for someone to confirm this bug in Mac OS X.
(Reporter)

Updated

9 years ago
Duplicate of this bug: 491959
It's OS X only.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 443178
You need to log in before you can comment on or make changes to this bug.