@font-face broken in FF3.5b4 after upgrading to Ubuntu 9.04

RESOLVED DUPLICATE of bug 489445

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 489445
9 years ago
9 years ago

People

(Reporter: Jonathan Vanherpe, Unassigned)

Tracking

({fonts})

3.5 Branch
x86
Linux
fonts
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b5pre) Gecko/20090508 Shiretoko/3.5b5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b5pre) Gecko/20090508 Shiretoko/3.5b5pre

After upgrading my box to Jaunty Jackalope, the @font-face thing seems broken. I see in Firebug that Firefox loads the fonts, but it shows weird boxes instead of the downloaded font. This worked in Intrepid, so it might be a bug in Ubuntu too (don't yell at me for reporting it here, it just seemed better to report it here since ubuntu doesn't ship with FF3.5b4).

I've tested this both on my main box and in a virtual machine, both running Ubuntu Jaunty Jackalope (both upgrades).

Reproducible: Always

Steps to Reproduce:
1.load any website that uses @font-face (forabeautifulweb.com, the demo page i posted)

Actual Results:  
Weird boxes with numbers in them (the thing Linux usually does when it has font display troubles)

Expected Results:  
You should see the font face that was embedded

This was just tested in Ubuntu Jaunty Jackalope, and is probably related to some change in X or Ubuntu itself. It worked perfectly in Intrepid.
I'll add a screenshot later.
(Reporter)

Comment 1

9 years ago
Created attachment 376404 [details]
screenshot of font-face-embed demo page
(Reporter)

Comment 2

9 years ago
I forgot to mention that as you can see in the screenshot I also looked at the latest trunk build of FF (3.5b5pre), because I wanted to check if this was fixed before reporting. I see it both in 3.5b4 and this.
(Reporter)

Updated

9 years ago
Keywords: fonts
Version: unspecified → 3.5 Branch

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 489445
You need to log in before you can comment on or make changes to this bug.