Cannot accept/decline invalid certificate

RESOLVED DUPLICATE of bug 469848

Status

Fennec Graveyard
General
RESOLVED DUPLICATE of bug 469848
8 years ago
8 years ago

People

(Reporter: jhford, Unassigned)

Tracking

Details

Attachments

(1 attachment)

It is currently impossible for the user to deal with an invalid SSL certificate.  The buttons needed to accept or dismiss the certificate are not being shown where needed.  In the simulator build I tested there is a button.  hg id for m-c is c61fc3216701 and for mobile-browser is 67f0a1e34573

Steps to reproduce:
1-Load fennec
2-Navigate to https://mozilla.org (ssl, no www)
3-Click "Or you can add an exception..."
4-In the secure connection failed pop up click "View Certificate"

Actual Outcome:
-There is no UI visible to accept or dismiss screen
-User must click enter on the keyboard but does not know which button they are pressing
-It is impossible to leave this popup window without pressing enter on the keyboard

Desired Outcome:
-Button is visible

This is always reproducible
Created attachment 376488 [details]
UI of screen with missing button
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 469848
You need to log in before you can comment on or make changes to this bug.