If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

OSX ppc: History not saved

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Jeremy Huddleston, Unassigned)

Tracking

3.5 Branch
Firefox 3.5
PowerPC
Mac OS X
Points:
---
Bug Flags:
blocking-firefox3.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
This works on intel but not on ppc.  

The browser history is not stored.  I can not go back or forward.  Show all history is empty.  Privacy preferences has "Remember history". Bookmarks are not listed.  Bookmarks can not be created.

3.0.10 works.
3.1b3 fails
3.5b4 fails

I'll try b2 and b1.
Flags: blocking-firefox3.5?
(Reporter)

Comment 1

9 years ago
3.1b2 fails
3.1b1 works

Comment 2

9 years ago
try starting in safe mode with 3.5 b4

http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 3

9 years ago
Yeah, that has no discernible effect.

Comment 4

9 years ago
Did you create a new profile?

Comment 5

9 years ago
Also try PRAGMA integrity_check on SQLite

https://bugzilla.mozilla.org/show_bug.cgi?id=486905#c5
(Reporter)

Comment 6

9 years ago
It works from a vanilla user account, but not with my previous preferences.

The PRAGMA integrity_check returns 'OK' ... but there are 750 sqlite.places-###.corrupt files in my profile directory.

Comment 7

9 years ago
If the problem is with a profile from a previous version, you are probably seeing bug 477739, which was fixed in February.  Marco and Dietrich would know better though.
(Reporter)

Comment 8

9 years ago
Interestingly the first corrupt places.sqlite file is dated Feb 2.

Do you want me to keep my corrupted profile for analysis, or should I just backup my bookmarks from 3.0 and import them in 3.5?

Comment 9

9 years ago
I'm pretty sure we would like to check it out. Right Marco? Dietrich? Is it possible to tar/gzip it and place it somewhere for download? You can send an email to ddahl _AT_ mozilla dot com with the url.

Regards,

david
Or just send it via e-mail to one of the folks who have commented so far.
Flags: blocking-firefox3.5? → blocking-firefox3.5-
(Reporter)

Comment 11

9 years ago
This is a major problem for performance reasons as well.  I just used 3.5b4 for a minute or 2, and I had 12 places.sqlite-##.corrupt files in my profile.  After I had used it for an hour, I had over 1000 (wasting about 2G of disk space).

I never received confirmation of receipt of the profile.  Please ping me if you still need it.
Sounds like there's an endian issue in the startup path.
Could you please try next (15 May) trunk (3.6) nightly with a new profile? I'm curious about recent cleanup in startup path.
The build should be out in some hour from now.
well, i just tried both 3.5 and 3.6 PPC versions, and history is working fine, so it really looks like an issue with your profile. please send us your places.sqlite file by mail.

to have a working browser you can try removing all places.sqlite (and corrupt) files from your profile, and let the browser create a new one. You will lose history but bookmarks should be restored from json.
(Reporter)

Comment 14

9 years ago
I sent it twice already.  I'll send it again.  I already have a working profile, but I want to help get this fixed, so it doesn't mess up users when 3.5 ships.
I got the profile this time, and I suspect everyone else did as well.

Comment 16

9 years ago
How did you send it? I did not get it.
(Reporter)

Comment 17

9 years ago
I sent it as a mime encoded tarball (859vcy1i.default-492146.tar.bz2) from jeremyhu at apple.com with subject "profile for bug 492146"
(Reporter)

Comment 18

8 years ago
IIRC, this was a migration issue in some betas that never hit a release.  I believe this can be closed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
i think you're right, thanks for reporting back.
changing to WFM since no patch has been submitted in this bug.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.