<select> form control with multiple <option>s with the same @value selects the last option on reload

RESOLVED DUPLICATE of bug 201056

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 201056
9 years ago
8 years ago

People

(Reporter: omzy83, Unassigned)

Tracking

3.6 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) )
Build Identifier: 

If you have a SELECT form control, which contains OPTIONS that have the same VALUE, Firefox will select the last option when the page is reloaded.

Reproducible: Always

Steps to Reproduce:
1. Navigate to http://www.yourasianlink.com, notice the dropdown menu at the top, it will default to "All Locations"
2. Hit Reload, and you will notice it selects the "--------------------------" option
3. This does not happen in any other browser
Actual Results:  
It selects the "--------------------------" option

Expected Results:  
It should keep the "All Locations" option selected.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

8 years ago
The issue still exists in Firefox 3.6.12

Updated

8 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Whiteboard: [CLOSEME 2010-11-01]
Version: unspecified → 3.6 Branch
(Reporter)

Comment 4

8 years ago
NOTE: Please test this bug on the following page:

http://www.yourasianlink.com/directory/djs/all-locations/

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Summary: select form control behaviour → <select> form control with multiple <option>s with the same @value selects the last option on reload
Duplicate of bug: 201056
You need to log in before you can comment on or make changes to this bug.