credits.xhtml update for 3.5 release

RESOLVED FIXED

Status

()

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: johnath, Assigned: beltzner)

Tracking

({fixed1.9.1})

3.5 Branch
fixed1.9.1
Points:
---
Bug Flags:
blocking-firefox3.5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 1 obsolete attachment)

(Reporter)

Description

10 years ago
The addition that started this bug was:

Rob Stradling

but there may well be others.
Flags: blocking-firefox3.5?
Is this credits in about:credits or credits in About Firefox > Credits ?
(Reporter)

Comment 2

10 years ago
Lord help us all, but we do make this complicated, don't we?  :)  I meant credits.xhtml,

http://mxr.mozilla.org/mozilla-central/source/browser/base/content/credits.xhtml

which gets included in the About Firefox->Credits box. That's the one in-product, managed by mconnor.

about:credits is actually just a redirect to http://www.mozilla.org/credits/, which is maintained by Gerv. He prefers to handle these via email to credits@mozilla.org, but I'll cc him here in case it helps him spot people he might have missed (even though the lists are not semantically equivalent).

In the case of Rob, he should be on both lists.
(Reporter)

Updated

10 years ago
Summary: Credits update for 3.5 release → credits.xhtml update for 3.5 release
Flags: blocking-firefox3.5? → blocking-firefox3.5+

Comment 3

10 years ago
Graeme McCutcheon
Nochum Sossonko
Okay, I would ask that people email me nominations, as this isn't something I'm comfortable handling with public nominations.  Thanks.
We on track to get an update committed today?
Connor, happy to work on this for you if you send me the list ...
The problem is that I think the list is incredibly short and missing names, the patch itself is trivial...
(Reporter)

Comment 9

10 years ago
Comment on attachment 378922 [details] [diff] [review]
first rev


>+            <li>David Dahlt</li>

Dahlt -> Dahl
Pointed out, fixed.  This landed branch/trunk already.
yay
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.9.1
Resolution: --- → FIXED
Does "first rev" mean that there's more to come? If so, should this be reopened?
Connor indicated (out of band) that he'd be done in a few hours, many many hours ago, so I'm presuming that whatever needed to land has landed.
No, I got pulled into blocker reviews, but I've got the data for a bunch more contributors.  We shouldn't block on this, but I'll get it together ASAP anyway.
"more" still needs to land, right?
Created attachment 382833 [details] [diff] [review]
even more

"more" landed already, but hadn't

this will land shortly
Aakash Desai ?

Comment 19

10 years ago
Tomomi Kato (Mozilla Japan, marketing manager)

Comment 20

10 years ago
Michael Yoshitaka Erlewine (Mozilla Labs, Ubiquity l10n, contractor)
Comment on attachment 379232 [details] [diff] [review]
more

>+            <li>Matthew Noorenberghe </li>

Excess space.

Comment 22

10 years ago
from attachment 378922 [details] [diff] [review] 

> @@ -382,16 +386,17 @@
>             <li>Kaori Negoro</li>

Please be sure to delete Kaori Negoro from credits.
Assignee: mconnor → beltzner
Status: RESOLVED → REOPENED
Keywords: fixed1.9.1
Resolution: FIXED → ---
Created attachment 384631 [details] [diff] [review]
gen and joduinn's edits
Attachment #384631 - Flags: review?(gavin.sharp)
Attachment #384631 - Flags: approval1.9.1+
Comment on attachment 384631 [details] [diff] [review]
gen and joduinn's edits

(missing some names, mike will update)
Attachment #384631 - Flags: review?(gavin.sharp) → review-
At least in my alphabet, Gas comes after Gar
Created attachment 384632 [details] [diff] [review]
gen and joduinn's edits v2

Aakash & Tomomi added, excess space removed, didn't add Gen's other suggestion as this is Firefox contributors only atm.
Attachment #384631 - Attachment is obsolete: true
Attachment #384632 - Flags: review?(gavin.sharp)
Attachment #384632 - Flags: approval1.9.1+
Attachment #384632 - Attachment is patch: true
Attachment #384632 - Attachment mime type: application/octet-stream → text/plain
Attachment #384631 - Flags: approval1.9.1+
If it's not too late, can we also add:
  Keith Schwarz
(He's an intern from last summer who implemented -moz-transform, one of the awesome new CSS features in Firefox 3.5)
Well, we're not holding the RC for this, so whatever gets in by the time we lock down, gets in.

Updated

10 years ago
Attachment #384632 - Flags: review?(gavin.sharp) → review+
Comment on attachment 384632 [details] [diff] [review]
gen and joduinn's edits v2

r+ for the additions, I made a decision when we started this that we weren't getting into culling the list this cycle, because that's a process that we should either apply across the board or not at all.

Comment 34

10 years ago
Comment on attachment 384747 [details] [diff] [review]
more

>diff --git a/browser/base/content/credits.xhtml b/browser/base/content/credits.xhtml

>+            <li>Rick Reitmeier</li>

That should be "Rick Reitmaier".
I look forward to the change in comment 34 making it along with the rest of this patch on to trunk. This bug is entirely, all-the-way closed for firefox1.9.1. If anyone checks in additional fixes there, they should be prepared to justify why they've done so.
(In reply to comment #35)
> I look forward to the change in comment 34 making it along with the rest of
> this patch on to trunk. This bug is entirely, all-the-way closed for
> firefox1.9.1. If anyone checks in additional fixes there, they should be
> prepared to justify why they've done so.

I checked in a fix for the typo on the 1.9.1 relbranch and tip, and on trunk, so that it will be included *if* we spin rc3build2. I didn't make any additional changes.
Gavin: so is this fixed on trunk, then?
Yeah, I guess so.
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
(In reply to comment #22)
> from attachment 378922 [details] [diff] [review] 
> 
> > @@ -382,16 +386,17 @@
> >             <li>Kaori Negoro</li>
> 
> Please be sure to delete Kaori Negoro from credits.

He is still in the list. Further I miss Heather Arthur.
You need to log in before you can comment on or make changes to this bug.