Notification bars on OS X should not draw a focus ring on buttons

RESOLVED FIXED in Firefox 3.7a5

Status

()

Firefox
Theme
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: faaborg, Unassigned)

Tracking

({polish})

Trunk
Firefox 3.7a5
x86
Mac OS X
polish
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 376818 [details]
Focus ring being drawn on a notification bar button on OS X

This is actually a regression, although I am not sure what the range is.  I'm also not sure what caused the problem to appear, but the buttons in notification bars now draw a focus ring when you interact with them using the mouse (including the small close button).  It is possible that we've previously been relying on images (similar to the toolbar buttons in the OS X them) so the focus ring wasn't showing up, but now that these are being exposed as buttons, they pick up bug 418521

Screen shot attached
(Reporter)

Updated

9 years ago
Depends on: 418521
Maybe bug 476370 caused this? ;-)
Blocks: 476370
(Reporter)

Comment 2

9 years ago
ah, right, sec508 violation.  Ok, we might as well keep this around since it depends on 418521.  Nothing to see here, move along :)
fixed by bug 418521
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a5
You need to log in before you can comment on or make changes to this bug.