File not found after selected if location field path omits trailing "/"

VERIFIED DUPLICATE of bug 48200

Status

()

Core
Networking
P3
major
VERIFIED DUPLICATE of bug 48200
18 years ago
18 years ago

People

(Reporter: Jimmy Lee, Assigned: Gagan)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Build: 2000-08-16-10-M18(WIN), 2000-08-16-10-M18(MAC), 2000-08-16-09-M18(LINUX)

1. Launch Netscape 6
2. From Location field, type "http://jimbob/jars" (any directory is ok, but 
   must omit trailing "/")
3. Click on any html file in directory such as a_skin_classic2.html

RESULT:
Page displays "Not Found".  Location field shows 
"http://jimbob/a_skin_classic2.html".

EXPECTED RESULT:
Page is found.  Location field shows "http://jimbob/jars/a_skin_classic2.html".

DETAILS:
The main thing here is that there is no trailing "/" in "http://jimbob/jars".  
If a trailing "/" is entered, then there is no problem.  If one clicks to this 
HTML file from "http://jimbob/", then there is no problem.  No problem exists if 
a bookmark is used or the full path "http://jimbob/jars/a_skin_classic2.html" is 
entered.
(Reporter)

Comment 1

18 years ago
Nominating for nsbeta3.  Although it is possible to open a file in different 
ways, this particular approach is very common.  This is the kind of bug that can 
be repeated by end users over and over again to the point where it becomes 
extremely annoying.  I believe this bug is high impact versus high severity.
Keywords: nsbeta3

Comment 2

18 years ago
(Changed my mind from an earlier conversation...). I think this should go
to necko (or perhaps to SH). This bug has pretty broad consequences: any
URL that points to a directory, but omits the (optional) trailing slash
will wind up resolving relative references incorrectly for that page. 
Assignee: don → gagan
Component: XP Apps → Networking
QA Contact: sairuh → tever

Comment 3

18 years ago
Created attachment 13024 [details]
testcase: points to a directory on www.mozilla.org; first example resolves relative URL's incorrectly

Comment 4

18 years ago
The attachment points to www.mozilla.org/xpfe, which contains the HTML

<P><B>Elevator Story</B>: <A HREF="ElevatorStraightUp.html">straight
up</A> or <A HREF="ElevatorTouchyFeely.html">touchy-feely</A>.</P>

Clicking on the link in the attachment that lacks the trailing slash and 
then clicking on one of the relative URL's above, results in the wrong
resolution of the absolute URL to visit. 
added radha and claudius.

Comment 6

18 years ago
raising severity to major. cc:shrir
Severity: normal → major

Comment 7

18 years ago
Is this a manifestation of bug 48200? (I think so)

Pretty serious problem!

Comment 8

18 years ago
Adding myself to Cc list.
(Assignee)

Comment 9

18 years ago
this is a dup. 

*** This bug has been marked as a duplicate of 48200 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 10

18 years ago
verif. DUP
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.