Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 492885 - Scroll wheel on mouse fails to allow page to scroll
: Scroll wheel on mouse fails to allow page to scroll
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 3.5 Branch
: x86_64 Windows 7
: -- major with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
Depends on:
  Show dependency treegraph
Reported: 2009-05-13 16:53 PDT by Luke Bearl
Modified: 2011-05-10 20:51 PDT (History)
11 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Luke Bearl 2009-05-13 16:53:36 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b5pre) Gecko/20090512 Shiretoko/3.5b5pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b5pre) Gecko/20090512 Shiretoko/3.5b5pre (.NET CLR 3.5.30729)

When navigating to a page that requires the use of the scroll bars, the scroll wheel on the mouse (and scroll touch bar on the touch pad) fail to scroll the page.  

Reproducible: Always

Steps to Reproduce:
1. Navigate to
2. Enter search query "Waldo"
3. Attempt to scroll using scroll wheel, note failure.
Actual Results:  
The window failed to scroll

Expected Results:  
The window should move down (if possible) on a scroll down event, or up in a scroll up event.

Currently using the nightly build (Build 20090512041901) with the default theme.  Currently using Adblock plus, download statusbar, downthemall!, edit middle, firebug, fireftp, flashgot, google preview, greasemonkey, httpfox, ie tab, microsoft .net framework assistant, nightly tester tools, twitter fox, user agent switcher, and window resizer plugins.
Comment 1 Kevin Borgnis 2009-05-15 06:22:03 PDT
I'm having the same issue. Also, the scroll bar moves to the left side of the window after clicking on another tab and then clicking back or refreshing the page.  After scroll wheel stops working, links also apparently stop working.

Manually manipulating the scroll buttons causes the page to scroll normally.

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Comment 2 Luke Bearl 2009-05-15 14:07:10 PDT
In addition to what I described above, using the scroll wheel also snaps the scroll bar to the top of the screen.
Comment 3 jim bruce 2009-06-27 13:39:18 PDT
about:config change general.autoScroll to true seems to fix
Comment 4 peter 2009-08-09 04:01:23 PDT
general.autoScroll is true here, and I cant scroll with the mousepad scroll button either on a lenovo x60s
Comment 5 Xagest 2009-11-12 12:06:37 PST
I'm also feeling this issue, running a Lenovo T61p laptop.  Both the mouse (tried 3 separate mice) and the touchpad fail to scroll
Comment 6 saint_the_hell_raiser 2009-11-17 07:54:51 PST
Same issue in Dell Stuio-XPS 16. Upated to new drivers, version of firefox. Works well in all other browsers. Shame as I have to use other browsers for this reason.
Comment 7 peter 2009-11-17 07:58:38 PST
Is there any progress on this issue?
Comment 8 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2010-01-18 05:37:32 PST
Hello everyone.  Sorry for the delay in response.  For those of you with Lenovo computers, can you turn off whatever preference changes you made (e.g. comment 3) and try scrolling on either the 3.6 release candidate or a nightly build from trunk?  We made some changes in December that should have fixed the problems you're experiencing.
Comment 9 Ian 2010-01-21 13:47:12 PST
Upon downloading 3.6 final (en_GB) on a Thinkpad T60 (Windows XP 32-bit) with a Lenovo scroll point mouse, the scroll point (wheel substitute) does not work, but did in 3.5.7 and below.

I have not found any settings in about:config to get scrolling to work again.

The scroll point works (at least for vertical scrolling) in all other applications.
Comment 10 gbb0330 2010-03-18 06:16:24 PDT
same problem here, installed 3.6 and can't scroll anymore. using scroll point on IBM Thinkpad G40
Scrolling works in all other applications.

also changed a bunch of scrolling options in about:config with no luck.

however if i start Firefox in safe mode scrolling works.

Also uninstalled firefox and did a fresh install without addons - still no luck.
Comment 11 gbb0330 2010-03-18 06:17:39 PDT
also see this thread, its a legit issue - seems to be limited mostly to IBMs with track point.
Comment 12 Tyler Downer [:Tyler] 2010-12-31 10:00:10 PST
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version,
Comment 13 gbb0330 2011-01-04 11:47:44 PST
Just updated to 3.6.13 and the issue is still unresolved. I tried it in safe mode too, also tried changing autoscrolling and smooth scrolling. So i am back Chrome.
Comment 14 Tyler Downer [:Tyler] 2011-02-01 21:58:12 PST
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile ( If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Comment 15 gbb0330 2011-02-02 07:21:12 PST
I just tested scrolling with a new profile on 3.6.13 and on 4.0 Beta 10.
Still unable to scroll using track point.
Comment 16 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-02-02 07:23:33 PST
Not sure why this was closed, the reporter clearly replied ...
Comment 17 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-02-02 07:24:51 PST
Or, I suppose the reporter didn't, but someone did.

gbb0330:  can you figure out what sort of mouse drivers your system has (e.g. Synaptics, Alps, etc) and what version they are?
Comment 18 gbb0330 2011-02-02 07:30:22 PST
PS/2 TrackPoint
Comment 19 Luke Bearl 2011-02-02 07:36:00 PST
Firefox 4 beta 10 is working for scrolling for me, I replicated the exact changes.  Please note that I have a fresh install, and different plugins installed now, which indicates that this may be a plugin issue as others are still reporting failure with 4b10.
Comment 20 Tyler Downer [:Tyler] 2011-05-10 20:05:32 PDT
So Luke, you can no longer see this issue with Firefox 4 in a fresh profile?
Comment 21 Luke Bearl 2011-05-10 20:11:51 PDT
I have been having no issue with Firefox 4 on a fresh install.

Note You need to log in before you can comment on or make changes to this bug.