Scroll wheel on mouse fails to allow page to scroll

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Luke Bearl, Unassigned)

Tracking

3.5 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b5pre) Gecko/20090512 Shiretoko/3.5b5pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b5pre) Gecko/20090512 Shiretoko/3.5b5pre (.NET CLR 3.5.30729)

When navigating to a page that requires the use of the scroll bars, the scroll wheel on the mouse (and scroll touch bar on the touch pad) fail to scroll the page.  

Reproducible: Always

Steps to Reproduce:
1. Navigate to http://www.google.com
2. Enter search query "Waldo"
3. Attempt to scroll using scroll wheel, note failure.
Actual Results:  
The window failed to scroll

Expected Results:  
The window should move down (if possible) on a scroll down event, or up in a scroll up event.

Currently using the nightly build (Build 20090512041901) with the default theme.  Currently using Adblock plus, download statusbar, downthemall!, edit middle, firebug, fireftp, flashgot, google preview, greasemonkey, httpfox, ie tab, microsoft .net framework assistant, nightly tester tools, twitter fox, user agent switcher, and window resizer plugins.

Comment 1

8 years ago
I'm having the same issue. Also, the scroll bar moves to the left side of the window after clicking on another tab and then clicking back or refreshing the page.  After scroll wheel stops working, links also apparently stop working.

Manually manipulating the scroll buttons causes the page to scroll normally.

User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
(Reporter)

Comment 2

8 years ago
In addition to what I described above, using the scroll wheel also snaps the scroll bar to the top of the screen.

Comment 3

8 years ago
about:config change general.autoScroll to true seems to fix

Comment 4

8 years ago
general.autoScroll is true here, and I cant scroll with the mousepad scroll button either on a lenovo x60s

Comment 5

8 years ago
I'm also feeling this issue, running a Lenovo T61p laptop.  Both the mouse (tried 3 separate mice) and the touchpad fail to scroll
Same issue in Dell Stuio-XPS 16. Upated to new drivers, version of firefox. Works well in all other browsers. Shame as I have to use other browsers for this reason.

Comment 7

8 years ago
Is there any progress on this issue?
Hello everyone.  Sorry for the delay in response.  For those of you with Lenovo computers, can you turn off whatever preference changes you made (e.g. comment 3) and try scrolling on either the 3.6 release candidate or a nightly build from trunk?  We made some changes in December that should have fixed the problems you're experiencing.

Comment 9

8 years ago
Upon downloading 3.6 final (en_GB) on a Thinkpad T60 (Windows XP 32-bit) with a Lenovo scroll point mouse, the scroll point (wheel substitute) does not work, but did in 3.5.7 and below.

I have not found any settings in about:config to get scrolling to work again.

The scroll point works (at least for vertical scrolling) in all other applications.

Comment 10

7 years ago
same problem here, installed 3.6 and can't scroll anymore. using scroll point on IBM Thinkpad G40
Scrolling works in all other applications.

also changed a bunch of scrolling options in about:config with no luck.

however if i start Firefox in safe mode scrolling works.

Also uninstalled firefox and did a fresh install without addons - still no luck.

Comment 11

7 years ago
also see this thread, its a legit issue - seems to be limited mostly to IBMs with track point.

http://support.mozilla.com/en-US/forum/1/603456
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]

Comment 13

7 years ago
Just updated to 3.6.13 and the issue is still unresolved. I tried it in safe mode too, also tried changing autoscrolling and smooth scrolling. So i am back Chrome.
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE

Comment 15

7 years ago
I just tested scrolling with a new profile on 3.6.13 and on 4.0 Beta 10.
Still unable to scroll using track point.
Not sure why this was closed, the reporter clearly replied ...
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Whiteboard: [CLOSEME 2011-1-30]
Or, I suppose the reporter didn't, but someone did.

gbb0330:  can you figure out what sort of mouse drivers your system has (e.g. Synaptics, Alps, etc) and what version they are?

Comment 18

7 years ago
PS/2 TrackPoint
ver 3.55.0.0
Lenovo
(Reporter)

Comment 19

7 years ago
Firefox 4 beta 10 is working for scrolling for me, I replicated the exact changes.  Please note that I have a fresh install, and different plugins installed now, which indicates that this may be a plugin issue as others are still reporting failure with 4b10.
So Luke, you can no longer see this issue with Firefox 4 in a fresh profile?
Version: unspecified → 3.5 Branch
(Reporter)

Comment 21

6 years ago
I have been having no issue with Firefox 4 on a fresh install.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.