Rewrite: Manually convert nsComponentManager/xptinfo to use new thread synchronization API

RESOLVED DUPLICATE of bug 645263

Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 645263
9 years ago
7 years ago

People

(Reporter: cjones, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

It uses (the now deprecated) nsAutoLock.lock/unlock extensively, which means porky.py can't rewrite it automatically.  I don't feel comfortable rewriting it by hand.

Assigning to bsmedberg so that he can foist this off on someone else.
Correction: it was nsComponentManager that I didn't want to rewrite.  xptinfo was somehow involved in that in a way that I no longer remember.

For the record, porky was able to handle these rewrites, it's just that this code extensively used nsAutoMonitor.lock/unlock, which can't be rewritten automatically (easily).
Created attachment 377794 [details] [diff] [review]
Starting point for a rewrite

Here's what porky came up, both to defend its honor ;) and help out whoever works on this bug.
I should add that this patch needs to be applied at the mozilla-central top level using |patch -p0 < xptinfo.patch|.
Summary: Rewrite: Manually convert xptinfo to use new thread synchronization API → Rewrite: Manually convert nsComponentManager/xptinfo to use new thread synchronization API

Updated

8 years ago
Assignee: benjamin → nobody
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 645263
You need to log in before you can comment on or make changes to this bug.