Closed Bug 493364 Opened 11 years ago Closed 11 years ago

can't build with --disable-dbm option when not cross-compiling

Categories

(NSS :: Build, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED
3.12.4

People

(Reporter: kou, Assigned: kou)

Details

Attachments

(2 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko Kazehakase/0.5.6
Build Identifier: 

We can't build Linux and Windows (not Windows Mobile) version Fennec (XULRunner) with --disable-dbm option. "Linux and Windows" means that it's not cross-compiling.


Reproducible: Always

Steps to Reproduce:
1. add "ac_add_options --disable-dbm" .mozconfig
2. make -f client.mk build

Actual Results:  
Failed with the following message:
...
make -j1: *** No rule to make target /home/kou/work/mozilla/fennec-clean/xulrunner/dist/lib/libnssdbm3.chk.  Stop.
make[6]: *** [/home/kou/work/mozilla/fennec-clean/xulrunner/dist/lib/libnssdbm3.chk] error 1
...


Expected Results:  
No error.
Attached patch fix the problem. (obsolete) — Splinter Review
We don't have nssdbm3.$(DLL_SUFFIX) on --disable-dbm build.
Assignee: nobody → nobody
Component: General → Build
OS: Linux → All
Product: Fennec → NSS
QA Contact: general → build
Hardware: x86_64 → All
Version: Trunk → trunk
Attachment #377837 - Flags: review?(nelson)
Comment on attachment 377837 [details] [diff] [review]
fix the problem.

Please attach a CVS patch,
against the CVS trunk.
Attached patch CVS diffSplinter Review
I am sorry, I did not notice it.
Attachment #377837 - Attachment is obsolete: true
Attachment #378204 - Flags: review?(nelson)
Attachment #377837 - Flags: review?(nelson)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch related patchSplinter Review
Kouhei & Hiroyuki, 
Would you please test out this tiny patch for the same file and 
inform me if it works satisfactorily for you, together with your patch?
(This patch has windows line endings, so beware. :)
Comment on attachment 378204 [details] [diff] [review]
CVS diff

r=nelson
Attachment #378204 - Flags: review?(nelson) → review+
Priority: -- → P2
Target Milestone: --- → 3.12.4
(In reply to comment #4)

> Kouhei & Hiroyuki, 
> Would you please test out this tiny patch for the same file and 
> inform me if it works satisfactorily for you, together with your patch?
> (This patch has windows line endings, so beware. :)

It could be built fennec for WinXP without errors, and fennec.exe seems to be fine on WinXP. And shlibsign.exe is in dist/bin.
Assignee: nobody → kou
Status: NEW → ASSIGNED
Glen, 
Is the file nss/cmd/shlibsign/Makefile part of the frozen FIPS source code?
Whiteboard: FIPS?
Bob, 
Is the file nss/cmd/shlibsign/Makefile part of the frozen FIPS source code?
No.

bob
Checking in shlibsign/Makefile; new revision: 1.20; previous revision: 1.19
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: FIPS?
You need to log in before you can comment on or make changes to this bug.