on startup, multiple password request boxes open up.

VERIFIED DUPLICATE of bug 348997

Status

()

Firefox
Session Restore
VERIFIED DUPLICATE of bug 348997
9 years ago
9 years ago

People

(Reporter: Christian Höltje, Unassigned)

Tracking

3.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
What Happens:
  Start up Firefox.
  Ensure that "restore session" is turned on.
  Ensure that there is a master password set for password saving.
  Visit a page that requires a password via HTTP Auth, logging in.
  Open the same page into multiple tabs.
  Quit Firefox.
  Start Firefox.
  Notice that a Master Password request and then a confirm HTTP Auth dialog is opened per tab.
  This is the same with all my extensions disabled or enabled (see below).


What I Expected:
  The Master Password should be asked for only once.  When an HTTP Auth username/password is confirmed on one tab/page, then I expect it to used for all tabs.

System:
Ubuntu 9.4 using the official Firefox.com version: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10

Normally enabled extensions:
  * Firebug 1.3.3
  * Google Gears 0.5.19.0
  * Greasemonkey 0.8.20090123.1
  * It's All Text! (latest, I'm the developer)
  * Master Password Timeout 0.2.7
  * Stylish 1.0.1
  * Tree Style Tab 0.7.2009051501
  * Web Developer 1.1.

I also have these extensions installed but normally disabled:
  * Clustybar 1.3.3
  * Restarter 1.0


Notes:
  I thought this would have been reported before but I couldn't find it no matter what search terms I used.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348997
(Reporter)

Comment 2

9 years ago
Thanks.  I couldn't believe that it hadn't been reported already.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.