Add max/average pause time, alloc volume to memstats

VERIFIED FIXED in flash10.1

Status

Tamarin
Garbage Collection (mmGC)
P2
normal
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: Tommy Reilly, Assigned: Lars T Hansen)

Tracking

(Blocks: 1 bug)

unspecified
flash10.1
x86
Mac OS X
Dependency tree / graph
Bug Flags:
flashplayer-qrb +

Details

(Reporter)

Description

9 years ago
In addition it would be great the know the cause of the max, an initial list would be:

StartIncremental
IncrementalMark
FinishIncremental
ZCT reap
User full collection request
(Assignee)

Comment 1

9 years ago
Also, pause clustering matters, so we might want to record clusters.  A pause cluster is a bunch of back-to-back pauses.  As a first approximation I would say that some pauses are within a cluster if all are within some set limit of each of its neighbors.  The limit may depend on CPU speed.

The pause logging probably belongs in the policy manager, because it already has the start/end events for each of these (or should have them).
(Reporter)

Updated

9 years ago
Summary: Add max/average pause time to memstats → Add max/average pause time, alloc volume to memstats

Updated

9 years ago
Flags: flashplayer-qrb+
Priority: -- → P2
Target Milestone: --- → flash10.x

Updated

9 years ago
Assignee: nobody → lhansen

Updated

9 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

9 years ago
Blocks: 486504

Updated

9 years ago
Assignee: lhansen → rishah
(Assignee)

Updated

9 years ago
Assignee: rishah → lhansen
(Assignee)

Updated

9 years ago
Blocks: 499965
No longer blocks: 486504
(Assignee)

Comment 2

9 years ago
Logging code (in GC::DumpMemoryInfo) will be provided with the other logging code for bug #486504.
Depends on: 486504
(Assignee)

Comment 3

9 years ago
Fixed by attachment #11 [details] in bug #486504.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 4

9 years ago
http://hg.mozilla.org/tamarin-redux/rev/97895d3b4a26
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.