protection against javascript infinity loops

RESOLVED DUPLICATE of bug 61098

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 61098
9 years ago
9 years ago

People

(Reporter: d, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; sv-SE; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; sv-SE; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

This is a request for a protection against javascript infinity loops. Basically, Firefox would analyze the JS code and if it looks like an infinity loop it should alert the user, asking if he/she would like to run the script or not. Of course, you should be able to disable this check.

Reproducible: Always

Actual Results:  
It runs until the browser crashes.

Expected Results:  
It should alert the user that this script will run forever and eventually crash the browser.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 61098
(Reporter)

Comment 2

9 years ago
In my opinion this isn't a duplicate of that bug. This would alert before the script runs, and only for infinity loops.
You need to log in before you can comment on or make changes to this bug.