HTTP status return code isn't passed correctly to Flash Plugin

RESOLVED DUPLICATE of bug 347805

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 347805
9 years ago
9 years ago

People

(Reporter: Mike Battistella, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

When using HTTP connections in ActionScript (Flash) status code 0 is returned instead of the actual code if the server responses with a HTTP status code other than 200.  InternetExplorer passes the code correctly. Adobe says that it's not correctly passed from the browser through the plugin API.

Reproducible: Always

Steps to Reproduce:
Use following code (close to Adobe's Reference Docs):

		private var cvisLoader : URLLoader;

		private function onHttpStatus ( e : HTTPStatusEvent ) : void {

			if ( e.status == 410 ) {
				grayMsgBox.msg.text = 'Resource is gone';
				grayMsgBox.visible = true;	
			}
		}

		cvisLoader.addEventListener ( "httpStatus", onHttpStatus );
Actual Results:  
Status code 0 is returned instead of the actual code. InternetExplorer passes the code correctly.

Expected Results:  
All Codes from 100-500 should be returned exactly to the plugin.

This bug shows in Firefox 2.x and 3.x with all Flash Player Versions >= 9
(Reporter)

Comment 1

9 years ago
The shown code snippet is ActionScript 3 (not JS, I forgot to mention)
Never, really never compare IE5+ (ActiveX plugins) with NPAPI based browsers (all browsers including IE4).
If this is an API limitation then Adobe or some other plugin vendor should file an enhancement request about what exactly they need. Your informati8on isn't enough because we know nothing, really nothing about flash and Actionscript.

But Adobe and others already reported this, marking as dupe of bug 347805
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 347805
You need to log in before you can comment on or make changes to this bug.