Last Comment Bug 49397 - Linux ONLY: Users run application from other directory encounter Mail & News problems
: Linux ONLY: Users run application from other directory encounter Mail & News ...
Status: RESOLVED INCOMPLETE
[nsbeta3-][cut 8/28] relnote-user
: pp
Product: SeaMonkey
Classification: Client Software
Component: MailNews: Message Display (show other bugs)
: Trunk
: x86 Linux
: -- major with 10 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 49403 (view as bug list)
Depends on:
Blocks: 49403
  Show dependency treegraph
 
Reported: 2000-08-17 16:55 PDT by Karen Huang
Modified: 2013-03-09 04:07 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
attached 4.x preferences.js (5.62 KB, text/plain)
2000-08-17 18:28 PDT, Karen Huang
no flags Details
Attached 6.0 prefs.js file (14.53 KB, text/plain)
2000-08-17 18:30 PDT, Karen Huang
no flags Details
rrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr (410 bytes, message/rfc822)
2003-01-30 06:50 PST, Eino Jakku
no flags Details

Description Karen Huang 2000-08-17 16:55:59 PDT
Used 08-17-08-M18 commercial build for Linux & Mac platforms:

Got an Alert when trying to save "viewed Inbox message" as template

1) Login to a migrated IMAP mail account's profile w/ save as template on 
server's template folder
2) After viewed some messages from the Inbox and selected one message.
3) Tried "File|Save As|Template" for above selcting message
4) Got an Alert: "Unable to save the message. Please check your file name and 
try again later"

Expected results: Should save the viewed Inbox message to the server template 
folder without this Alert.

Additional Info: Problem is not occurring on Windows platform, it's only 
occurring on Linux & Mac platforms
Comment 1 Karen Huang 2000-08-17 16:58:08 PDT
step 1) is describing setup the template save as server's template folder.
Comment 2 Karen Huang 2000-08-17 16:59:01 PDT
Adding pp on the keywords since it is only occurring on Linux & Mac platforms.
Comment 3 laurel 2000-08-17 17:20:22 PDT
Hmm... I just tried with migrated IMAP profile set to save to Templates on the
IMAP account, had no problem.  Using 2000-08-17-13 linux rh6.0 and 2000-08-17-08
mac OS 9.0.

I went to Karen's cube and checked the migrated 6.0 account settings to see
where her Templates pref was pointing to.  It was set to "Choose a folder",
indicating the setting didn't migrate right.  I know there's an old old bug
(pre-beta1 I think) about migrating and getting the Choose a Folder setting. I
will look that up.

However, in this case with Templates, the error message should not refer to a
File name but should point user to account settings.
Comment 4 laurel 2000-08-17 17:49:41 PDT
Well, I checked for Seth bugs about migrating and getting bad settings for the
copies & folders... I didn't see one.  I know we have/had several bugs about the
bad pref after migration.  cc esther, she may remember. 
Comment 5 laurel 2000-08-17 18:22:52 PDT
OK, Karen's setup on linux fails silently (no alert) when trying to save
Template from a (migrated) News account from the same migration.  No alert, but
the Templates folder never gets the saved message.  I made sure I'm actually
getting saved templates both for my (linux) IMAP and news accounts migrated in
the same way.

We glanced over Karen's preferences.js (4.x) and prefs.js (6.0) for the migrated
profile and nothing jumped out as garbage characters or incomplete paths for the
copies & folders prefs.  Don't know what caused this...
Comment 6 Karen Huang 2000-08-17 18:25:20 PDT
Laurel & I tried to get a clue why hers is working and mine is not working.
It should be something causing this problem....
I am just attaching two prefs.js as folowing for both 4.x & 6.0, hope developers 
can find the clue.....
Comment 7 Karen Huang 2000-08-17 18:28:58 PDT
Created attachment 13095 [details]
attached 4.x preferences.js
Comment 8 Karen Huang 2000-08-17 18:30:41 PDT
Created attachment 13096 [details]
Attached 6.0 prefs.js file
Comment 9 Karen Huang 2000-08-18 17:53:22 PDT
With the correct preference setup for 4.x and migrated to 6.0, I am still having
this problem on today's Linux build (08-18-06-M18 commercial build).
I suspect this is Linux environmental problem, I still need to investigate more
for this problem specific on Linux platform .....
Comment 10 Karen Huang 2000-08-22 16:59:30 PDT
Yes. This is Linux environmental causing Seamonkey Mail & News problems.
By using 08-21-12-M18 commercial build, I did the investigation as following:

1) If users install seamonkey under their home directory (ex:/home/khuang or
/u/huang) and running the application from there, there will be no problem at
all for save as template for viewed messages for both Mail & News.

2) If users install seamonkey under root environment(ex:/usr/netscape) and
running the application from there by access as root, there will be no problem
at all for save as template for viewed messages for both Mail & News.

3) If users install seamonkey under root environment(ex:/usr/netscape) and
running the application from user environment & access as user, problem will
occur as I described for save as template for viewed messages for both Mail &
News:

* Mail:

- Profile Info: doesn't matter whether users use migrated profile or not since
problem is also occurring on NEW profile.

- Preference Info: doesn't matter whether users set the save as template to
local or server, both will display the same Alert: "Unable to save the message.
Please check your file name and try again later"

- If tried to send the messages, will send successfully but received an Alert: "
Your send operation was successful, but copying the message to your Sent folder
failed, would you like to return to the compose window?" , After select OK will
encounter bug 49403 problem....

*News:
- Preference Info: 
  > If users set the "save as template" to server -- no Alert at all, didn't    
save the news messages as template at all, nothing happened.
  > If users set the "save as template" to local -- it crash right away
everytime.

** In the UNIX/Linux environment, since users can also install the application
from other location (ex: /usr/subdirectory),and there is crash occurring for
news for running same scenario, I am nominating this bug nsbeta3.

Updating the summary to reflect the real problems.

Reassign to Seth since this is specific for Linux problem 
Ccing Alec since Alec probably knows what is causing this problem.....

Comment 11 Karen Huang 2000-08-22 17:02:27 PDT
Nominating nsbeta3 this time.
Comment 12 lchiang 2000-08-23 16:03:10 PDT
*** Bug 49403 has been marked as a duplicate of this bug. ***
Comment 13 lchiang 2000-08-23 16:19:53 PDT
+, P2 per mail triage.

Karen - try this on other platforms.  For example, on Windows, make the install 
directory non-writeable.  What happens if you try some of the items you mention 
in this bug report after you make the install directory non-writeable?

Perhaps we are writing temp files to a directory where the user has no 
permission to do so?
Comment 14 Karen Huang 2000-08-24 16:08:55 PDT
No problem at all On Windows even after I make the install directory 
non-writeable. I can save copy of send messages, save as template for viewed 
messages for both Mail & News. 
Comment 15 lchiang 2000-08-28 18:28:30 PDT
second pass: - per mail triage
Comment 16 scottputterman 2000-10-19 18:31:52 PDT
Sorry for the extra mail. Removing mail4 keyword.
Comment 17 (not reading, please use seth@sspitzer.org instead) 2000-12-22 14:15:18 PST
clearing milestone, m17 and m18 are meaningless now.  these need to be triages
along with the rest.
Comment 18 Gabriel Billington 2002-01-24 11:03:33 PST
Non-root users also are unable to deselect the option to save a copy of outgoing
mail.  Root can deselect it fine.

Non-root users can uncheck the box, but it has no effect.  Every time the
Account Settings screen is brought back up, "Place a copy in:" is selected under
Copies & Folders, and any different options besides "Sent Folder" are undone.
Comment 19 art sulger 2002-05-16 05:40:47 PDT
I've never been able to keep settings for 'save sent' 'save draft' or 'save
template'. The dialog allows me to choose, then I shut down all instances of
Mozilla and they come back unset. Current version is release candidate 2, but
this behavior has been at least back to .98
I installed previous releases as root, but this time installed as user; same
behavior.
I'm running Redhat 7.2, KDE 2.2-11.
Comment 20 Gilbert Fang 2002-09-06 01:04:49 PDT
Mozilla 1.1b nightly build 
Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1b) Gecko/20020901
I am not very sure  what I do is right to exam this bug, but mozilla works well
for me . 
I create a new profile,  create a foler Templates. It is funny that mozilla
think this folder is special because the icon for this folder is not like
others. Then I  save a inbox message as a template and everything is okay.
Comment 21 Eino Jakku 2003-01-30 06:50:10 PST
Created attachment 113101 [details]
rrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrrr

Mozilla 1.0 and 1.2 as well as Netscape 7.0 take some action with Send, when
installed as root: the time stamp of Send.msf changes, but the Send file itself
does not. So it does not make a copy to send folder, the only possibility to
get a copy seems to be: use CC the message to some address having different
name and e-mail address (if the name is the same it does not work) and forward
that back.
Comment 22 Kevin Basham 2003-05-19 17:59:04 PDT
Linux/Solaris:

(Running as a user and not as root.  I did not do the install)

Haven't been able to have copies directed to my Sent, Drafts and Templates
Folders since moving to Mozilla/NS7.x.  The 'Mail & News Accounts Settings' menu
has always been messed up.

Renamed my "Local Folders" directory to "Local"
edited "preferences.js" and "prefs.js" to reflect only "Local"

Everything works fine now and the menu options finally work perfectly.

It couldn't handle the  [space] between Local and Folders 

Comment 23 Andrew Schultz 2006-08-26 14:55:33 PDT
Are people still seeing this with recent SeaMonkey builds?  Are you using sudo to install as root (bad)?
Comment 24 Wayne Mery (:wsmwk, NI for questions) 2013-03-09 04:07:13 PST
(In reply to Andrew Schultz from comment #23)
> Are people still seeing this with recent SeaMonkey builds?  Are you using
> sudo to install as root (bad)?

Note You need to log in before you can comment on or make changes to this bug.