If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Release Notes for Bugzilla 3.4rc1

RESOLVED FIXED in Bugzilla 3.4

Status

()

Bugzilla
Documentation
--
blocker
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Max Kanat-Alexander, Assigned: Max Kanat-Alexander)

Tracking

Bugzilla 3.4
Bug Flags:
approval +
approval3.4 +
blocking3.4 +

Details

Attachments

(1 attachment, 5 obsolete attachments)

(Assignee)

Description

9 years ago
The biggest thing we need for the 3.4rc1 release is Release Notes. This actually wasn't too hard for 3.2 (the Template Toolkit stuff makes it much easier), and I don't expect it to be impossibly hard for 3.4 either, particularly since 3.4 is such a smaller release than 3.2.
Flags: blocking3.4+
(Assignee)

Comment 1

8 years ago
Hey manu, I know you mentioned that you wanted to work on relnotes. Are you working on these, or are you just working on the other smaller releases (which would be OK)? I just want to know, because we're just about ready to release 3.4rc1 and I'm going to do these release notes if you haven't started on them yet.

Comment 2

8 years ago
(In reply to comment #1)
>
> Hey manu, I know you mentioned that you wanted to work on relnotes. Are you
> working on these, or are you just working on the other smaller releases (which
> would be OK)?

I'll only be able to start on Tuesday so it's probably best you go ahead.
(Assignee)

Updated

8 years ago
Assignee: documentation → mkanat
(Assignee)

Comment 3

8 years ago
Created attachment 387171 [details] [diff] [review]
WIP

Here is a work in progress, containing most of the major features and code change notes.
(Assignee)

Comment 4

8 years ago
Created attachment 387173 [details] [diff] [review]
WIP 2

Added more features from bugs marked "relnote".
Attachment #387171 - Attachment is obsolete: true
(Assignee)

Comment 5

8 years ago
Created attachment 387176 [details] [diff] [review]
WIP 3

Now contains some of the Outstanding Issues.
Attachment #387173 - Attachment is obsolete: true
(Assignee)

Comment 6

8 years ago
Created attachment 387336 [details] [diff] [review]
v1
Attachment #387176 - Attachment is obsolete: true
Attachment #387336 - Flags: review?

Updated

8 years ago
Attachment #387336 - Flags: review? → review-

Comment 7

8 years ago
Comment on attachment 387336 [details] [diff] [review]
v1

>Index: template/en/default/pages/release-notes.html.tmpl

>+<h2><a name="v34_req">Minimum Requirements</a></h2>

This makes the title to be seen as an anchor. You must move </a> before the title.


>+<h3><a name="v34_feat_enter">Simple Bug Filing</a></h3>

Same problem here and for other <h3> titles.

Also, here and at several other places is "Bug" hardcoded, instead of $terms.Bug. This makes 009bugwords.t to fail.


>+<h3><a name="34_feat_see">"See Also" Field</a></h3>

The anchor name must start with "v34", not "34" alone.


>+  <li>When logging out, users are now redirected to the main page of
>+    [% terms.Bugzilla %] instead of an empty page.</li>

Must be [%+ ... %], else no whitespace is added before "Bugzilla". Either that or put "of" right before it.


>+  <li>If you input an invalid regular expression anywhere in
>+    [% terms.Bugzilla %], it will now tell you explicitly instead of failing
>+    cryptically.</li>

Same here.


>+<tr> <td>CGI</td>          <td class="req_new">3.21</td> </tr>

CGI 3.21 for Perl 5.8.x, but CGI 3.33 for Perl 5.10.x.


I didn't check all features one by one. I trust you listed them correctly. Everything looks good.
+<p>Users can now select what time zone they are in and Bugzilla will
+  adjust displayed times to be correct for their time zone. However,
+  time zones the user inputs are unfortunately still in 

times the user inputs

+<p>Here's an example: Let's say that we create a field called "Colors",
+  and we make the Product field "control the values" for Colors. Then we
+  add Blue, Red, Black, and Yellow as legal values for the "Colors" field.
+  Now we can say that "Blue" and "Red" only appear as valid choices in 
+  Product A, "Yellow" only appears in Product B, but "Black" <em>always</em>
+  appears.</p>

Maybe this paragraph can be dropped, or replaced by "see the docs for details"?
(Assignee)

Comment 9

8 years ago
(In reply to comment #7)
> >+<h2><a name="v34_req">Minimum Requirements</a></h2>
> 
> This makes the title to be seen as an anchor. You must move </a> before the
> title.

  This is a broader general regression in 3.4 that we need to fix, not a problem with the release notes. (We need to add a CSS rule for a[name].)

(In reply to comment #8)
> Maybe this paragraph can be dropped, or replaced by "see the docs for details"?

  I don't think there are any docs. The problem is that the paragraph above is pretty much incomprehensible, even to me, and I wrote it. It's the nature of the logic of the thing, not the writing, I think.
(Assignee)

Comment 10

8 years ago
Created attachment 387403 [details] [diff] [review]
v2

Address LpSolit and Wurblzap's comments, fix bugwords test failures, and fix HTML validation.
Attachment #387336 - Attachment is obsolete: true
Attachment #387403 - Flags: review?
(Assignee)

Comment 11

8 years ago
Created attachment 387408 [details] [diff] [review]
Actual v2

Accidentally uploaded the wrong one.
Attachment #387403 - Attachment is obsolete: true
Attachment #387408 - Flags: review?
Attachment #387403 - Flags: review?

Updated

8 years ago
Attachment #387408 - Flags: review? → review+

Comment 12

8 years ago
Comment on attachment 387408 [details] [diff] [review]
Actual v2

Looks good. r=LpSolit
(Assignee)

Updated

8 years ago
Flags: approval3.4+
Flags: approval+
(Assignee)

Comment 13

8 years ago
I've checked in the release notes as they are, but I will still take review comments from anybody who wants to point out errors or improvements, and check in the fixes afterward.

tip:

Checking in docs/lib/Pod/Simple/HTMLBatch/Bugzilla.pm;
/cvsroot/mozilla/webtools/bugzilla/docs/lib/Pod/Simple/HTMLBatch/Bugzilla.pm,v  <--  Bugzilla.pm
new revision: 1.6; previous revision: 1.5
done
Checking in template/en/default/pages/release-notes.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/pages/release-notes.html.tmpl,v  <--  release-notes.html.tmpl
new revision: 1.36; previous revision: 1.35
done

3.4:

Checking in docs/lib/Pod/Simple/HTMLBatch/Bugzilla.pm;
/cvsroot/mozilla/webtools/bugzilla/docs/lib/Pod/Simple/HTMLBatch/Bugzilla.pm,v  <--  Bugzilla.pm
new revision: 1.5.2.1; previous revision: 1.5
done
Checking in template/en/default/pages/release-notes.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/pages/release-notes.html.tmpl,v  <--  release-notes.html.tmpl
new revision: 1.33.2.3; previous revision: 1.33.2.2
done
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.