Closed Bug 494121 Opened 13 years ago Closed 12 years ago

When video skips duration scroll bar should move

Categories

(Core :: Audio/Video, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: BijuMailList, Unassigned)

Details

Thanks, bug 470639 - "skip video frames to ensure smooth audio" got fixed.

Now when video skips, I dont see the duration scroll bar moving.
Summary: Show at least 1 frame per second while skipping video to get smooth audio → When video skips duration scroll bar should move
Was this meant to be a reply to bug 494120?
no another UI issue, 
I think the events are not getting fired when the videos are skipped 
May be fixing bug 494120 can hide this issue
Justin, Because bug 494120 is fixed it will be difficult to recreate this bug.
So do we need to keep this bug?
It might be harder to reproduce now, but I think this could still be a problem.  I think we only fire timeupdate events when we play a frame, so when we're only playing audio and dropping frame data we won't fire any timeupdate events and the scrubber won't update.

Fixing this is probably just a matter of calling UpdatePlaybackPosition in the frame skipping loop.
Current time now advances smoothly while skipping to the next keyframe on trunk with the new builtin decoder backend.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.