Illegal applet thread state by removing stopThread privilege

CLOSED DUPLICATE of bug 50547

Status

P3
normal
CLOSED DUPLICATE of bug 50547
19 years ago
8 years ago

People

(Reporter: oliver.fels, Assigned: stanley.ho)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
If one removes the stopThread-Permission from the policy, leaving a site with an
applet trying to invoke the stopThread() method throws an AccessControl
Exception (as expected).
Returning to that page later, JRE throws an illegalThreadState error for the applet.
Reproduced with build 081707.

Comment 1

19 years ago
Re-assigning to Stanley Ho for investigation.  Copying Ed Burns on this bug so 
he's aware of the problem as well.
Assignee: drapeau → stanley.ho

Comment 2

19 years ago
confirming for evaluation
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

19 years ago
dup of bug 50547

*** This bug has been marked as a duplicate of 50547 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
Verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

18 years ago
Can not verify that it has been a duplicate of #50547, thought its been more related to 49292, anyhow, its time to close this now, as it seems to be fixed and my reporting mail address will be changed in the very near future.
Status: VERIFIED → CLOSED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.