jetpack related? crash in [@ NS_GetInnermostURI - nsDOMStorage::InitAsSessionStorage]

RESOLVED DUPLICATE of bug 494359

Status

()

--
blocker
RESOLVED DUPLICATE of bug 494359
10 years ago
6 years ago

People

(Reporter: rbango, Unassigned)

Tracking

({crash})

1.9.1 Branch
x86
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Possibly related - Bug 494359 contains some of the same stack.
Component: General → DOM: Mozilla Extensions
Keywords: crash
Product: Firefox → Core
QA Contact: general → general
Summary: Crash in session storage → Crash in nsDOMStorage::InitAsSessionStorage
Version: 3.5 Branch → 1.9.1 Branch
Summary: Crash in nsDOMStorage::InitAsSessionStorage → Crash in [@ nsDOMStorage::InitAsSessionStorage(nsIPrincipal*) ]

Comment 2

10 years ago
hey rey,  and particular thing you were doing when you hit the crash?
(Reporter)

Comment 3

10 years ago
Hey Chris. I had installed Shiretoko and accessed the profile that I was using for Fx 3.5b4. The crashes seemed to happen when I tried to access Jetpack's preferences either through the add-on manager or via "about:jetpack"

Comment 4

10 years ago
not able to reproduce with just jetpack installed on  Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090520 Shiretoko/3.5b5pre

rey, did you have any jetpack addons installed or just the jetpack framework?
Try installing Firebug as well?

Updated

10 years ago
Summary: Crash in [@ nsDOMStorage::InitAsSessionStorage(nsIPrincipal*) ] → jetpack related? crash in [@ nsDOMStorage::InitAsSessionStorage(nsIPrincipal*) ]

Comment 6

10 years ago
marcia: the filename in the crash report indicates it is indeed a duplicate.

some compilers are better about symbol information than others :(.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Summary: jetpack related? crash in [@ nsDOMStorage::InitAsSessionStorage(nsIPrincipal*) ] → jetpack related? crash in [@ NS_GetInnermostURI - nsDOMStorage::InitAsSessionStorage]
Duplicate of bug: 494359
(Assignee)

Updated

7 years ago
Crash Signature: [@ NS_GetInnermostURI - nsDOMStorage::InitAsSessionStorage]
(Assignee)

Updated

6 years ago
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.