<P> tag used as spacers between <LI> tags in unordered lists [P-Margin]

VERIFIED DUPLICATE of bug 35772

Status

()

Core
Layout
P2
normal
VERIFIED DUPLICATE of bug 35772
19 years ago
18 years ago

People

(Reporter: fishy, Assigned: buster)

Tracking

({testcase})

Trunk
x86
Windows 95
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][6/22])

(Reporter)

Description

19 years ago
Under Netscape Communicator, putting the <P> tag between <LI> tags allows you to
space you unordered lists.  However, this spacing does not work under mozilla
(as of the latest nightly build 4/10/99).  I'm not sure whether this is an error
or simply something that is not allowed under the actual html spec.


The following html snippet demonstrates what I mean:
----------------------------------------------------
<UL>
<LI>Blah
<P>
<LI>blah
</UL>
----------------------------------------------------


Versions I was using:
Netscape - 4.51
Mozilla - Tried to find version numbers.  couldn't find them.  Other than the
build id, which was 1999041010

Updated

19 years ago
Assignee: troy → kipp

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Severity: minor → major
Priority: P3 → P5
Summary: <P> tag used as spacers between <LI> tags in unordered lists → {compat} <P> tag used as spacers between <LI> tags in unordered lists
Target Milestone: M6

Comment 1

19 years ago
The page lays out correctly, according to the CSS and HTML4 specs. However, its
not compatible with nav4.

Updated

19 years ago
Whiteboard: [TESTCASE]

Comment 2

19 years ago
That's a definitive testcase there.

Comment 3

19 years ago
Another note for later: The reason no vertical space is introduced is because
the P element ends up empty (as it should). According to the HTML4 spec, empty P
elements should have no visual affect.

Updated

19 years ago
Severity: major → normal

Comment 4

19 years ago
Updating to default Layout Assignee...kipp no longer with us :-(

Comment 5

19 years ago
Why are you re-reassing layout bugs? Do NOT touch layout bugs.

The bugs are assigned to Kipp so they can stay neatly organized until we have a
new owner for the block/inline code.
(Assignee)

Updated

19 years ago
Summary: {compat} <P> tag used as spacers between <LI> tags in unordered lists → {compat} [BLOCK] <P> tag used as spacers between <LI> tags in unordered lists
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
(Assignee)

Comment 7

18 years ago
mine! mine mine mine!  all mine!  whoo-hoo!
Assignee: kipp → buster
With the recent decision to remove the ignoring of empty paragraphs, this should
fix itself. 

Removing "compat" keyword, as this is now a standard compliance issue.

David -- the empty paragraph here will now not collapse away. The margins on
this empty paragraph will in fact become rather important, which seems to me to
go completely against the spirit of the spec. Hmm... I hope you're happy! ;-)
Summary: {compat} [BLOCK] <P> tag used as spacers between <LI> tags in unordered lists → <P> tag used as spacers between <LI> tags in unordered lists [BLOCK]
Whiteboard: [TESTCASE]
BTW, see bug 35772 for the reasoning behind the change of the rules.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: P3 → P2
Summary: <P> tag used as spacers between <LI> tags in unordered lists [BLOCK] → <P> tag used as spacers between <LI> tags in unordered lists [P-Margin]
Marking 4xp. Nom. nsbeta2, recc. nsbeta2 6/22, becoming nsbeta3+ if miss. 
Backward compat. with behavior of Nav4 for basic HTML 3.2 content on the web. 
Lots of folks used these hacks to control spacing.
Keywords: 4xp, nsbeta2

Comment 11

18 years ago
[nsbeta2+][6/22]
Whiteboard: [nsbeta2+][6/22]
(Assignee)

Comment 12

18 years ago
this is a dup of 35772 (a more general bug that includes this case)

*** This bug has been marked as a duplicate of 35772 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 13

18 years ago
Agreed. Marking verified dup of 35772.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.