Empty table elements aren't formatted

VERIFIED DUPLICATE of bug 8113

Status

()

P3
minor
VERIFIED DUPLICATE of bug 8113
18 years ago
18 years ago

People

(Reporter: brodms, Assigned: karnaze)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-SMP i686; en-US; m18) Gecko/20000817
BuildID:    2000081713

When a table, table row, or table cell is empty, and has a background color or
image, Mozilla will not display the background.

Reproducible: Always
Steps to Reproduce:
1. Create an HTML page with a table such as the following:

<table height="100" width="100" border="1">
  <tr bgcolor="blue" width="100" height="50">
    <td width="30" bgcolor="green"> <table height="100" width="100" border="1"
bgcolor="yellow">
  <tr bgcolor="blue" width="100" height="50">
    <td width="30" bgcolor="green"> </td>
    <td width="70" bgcolor="purple"> X </td>
  </tr>
  <tr>
    <td bgcolor="orange" width="50" height="50"> X </td>
    <td bgcolor="red" width="50" height="50">  </td>
  </tr>
</table>

2. Load this page.


Actual Results:  Mozilla will lay out the four table regions properly, but will only
apply the background colors to the cells with an 'X' in them, but will
not apply background colors to the regions with no content.

Expected Results:  Mozilla should have colored the blank regions with the
specified background color, similar to the way it would if &nbsp; items were
placed in the blank regions. This is similar to the way IE5 renders the example.
The HTML 4.0 spec's table section is not clear on how empty table sections
should be rendered, but IE's treatment seems far more sensible than Mozilla's.


This bug may be related to 19961 (table cells don't obey height and width), but
I noted that the size of the empty spaces follows the height and width
attributes.

Comment 1

18 years ago
Well articulated bug. It's already been reported however.
bug 8113: "Empty cell's bgcolor not rendered"

*** This bug has been marked as a duplicate of 8113 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Verified dup of #8113
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.