Session restore started up with nothing

VERIFIED INCOMPLETE

Status

()

Firefox
Session Restore
--
critical
VERIFIED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: Rob Hagopian, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

I quit FireFox manually (File->Exit) to restart it as it was largely swapped out due to another app with a memory leak. I am not browsing privately and my options has "Firefox will: Remember history". There was no crash that I'm aware of. When I restarted I was presented with the default start page and my session completely disappeared. Very frustrating.

Add-ons:
Autopager 0.5.0.1
Flashblock 1.5.10
Google Gears 0.5.19.0
Java Quick Starter 1.0
Microsoft .NET Framework Assistant 1.0

Reproducible: Didn't try
Can you ensure that you had "When Firefox Starts: Show  My Windows and Tabs From Last Time"? Also, if you can try to reproduce this bug, that would be helpful.

Also, can you see if you have windows listed in your "History" > "Recently Closed Windows" menu. You *shouldn't* if your session was not restored, but if there are entries there it could be a problem related to that.
(Reporter)

Comment 2

9 years ago
Update: I confirmed the Options at the time in order to copy the exact text (your text is familiar; this is 3.5b4 so I guess it must have changed?). I did have History -> Recently Closed Windows and some looked promising but when I tried to restore them they all (3) came up with empty tabs.

Getting a little frustrated at the empty tabs I then quit and restarted firefox and, much to my surprise, my old (presumed lost) session came up! Webpages I had loaded in teh interm (i.e., bugzilla) showed up in the history/wonderbar searches but were not restored along with the prior session tabs.

Is it possible there's a race condition where the new instance wasn't able to detect the old process running (which would have been saving the old session or such)?

Comment 3

9 years ago
did you check to see there is a sessionrestore file in your profile?
Severity: normal → critical

Comment 4

9 years ago
I had a similar problem today (Firefox 3.5 RC2). Here's what happened:

- I had a lot of tabs open in Firefox on Friday, I quit it normally and turned the computer off
- when I turned it on today and started Firefox, my tabs were gone, there was just an empty page
- later, I uninstalled Firebug because I have problems with its console and wanted to reinstall it. I clicked the button to restart Firefox to refresh the add-ons. I had about 3 tabs open at that time.
- Firefox closed that window and opened a new blank one, without those 3 tabs.
- I pressed Cmd+Q in order to quit Firefox (I'm using a Mac), but it only closed the current window, the application didn't quit (it was active in the dock). When I pressed the Firefox icon in the dock, it just opened a new window. I repeated this several times, and I was unable to make it quit.
- Then I got angry and started pressing Cmd+Q repeatedly. At that point, Firefox finally quit, reloaded, and opened my tabs from the previous session... but not the last one, it was the one from Friday!

I don't know what to think of this...
Was a firefox.exe process in the taskmanager (in windows at at least)?
I'm having a similar recurring problem (though, not every time, and I haven't been able to isolate the cause yet).  I do have "When Firefox Starts: Show  My Windows and Tabs From Last Time" set.  This time, when it happened, I had this on the console:

SessionStore: The session file is invalid: TypeError: this._initialState.windows[0] is undefined

Bug 467248 may be the same issue, I'm not sure.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
I've had to also uncheck clear history when Minefield closes to get the tabs from the previous session to come up.
For me, I realized the setting 'show my windows and tabs from last time' doesn't look like it turns off the 'clear history when Minefield closes'.  So it looks like the History settings affect Session Restore regardless of the the Startup setting.
Saw this again today, caused this time by a browser update.  Once again, the same error as in comment 6.

Comment 10

8 years ago
I have similar problems on both Linux and Windows. On Linux (Ubuntu 9.10, Firefox 3.6 preview, build 20091123174406) Firefox always starts with a single empty tag. The History menu does indeed show the locations that I visited, but the tabs are not loaded, even though "Show my Windows and Tabs from last time" is selected. This happens even if I disable all my addons, and even if I exit firefox with the file menu.

On Windows (Vista, latest auto-updating build of Firefox 3.5) I often get a "session restore" dialog. The message varies. Sometimes it's "Your last session crashed", sometimes "your crashed session crashed again" and sometimes its "your last session is empty". This happens most often if I shut down Windows without exiting Firefox first.

Comment 11

8 years ago
(In reply to comment #10)
> latest auto-updating build of Firefox 3.5) I often get a
> "session restore" dialog. The message varies. Sometimes it's "Your last session
> crashed", sometimes "your crashed session crashed again" and sometimes its
> "your last session is empty". This happens most often if I shut down Windows
> without exiting Firefox first.

Still see this problem?
What if you kill firefox with task manager before shutting down windows?

I never shut down MS-Windows. But I do kill firefox task occasionally and restart firefox.  I had seen this problem once last year, but not in many months of running trunk (3.7). I normally have 100+ tabs.

Comment 12

7 years ago
humph, isn't your issue bug bug 495123?  Or are you implying this bug is the exact same thing?

Rob, are you still seeing this? 

I may be suffering burnout, but there doesn't seem to be a common or even clear symptom in this bug, like an error msg or bad sessionstore.js.  Perhaps better to close this and seek a bug with clearer symptoms?  
buglist, static: https://bugzilla.mozilla.org/buglist.cgi?bug_id=423800%2C402768%2C527340%2C450711%2C525681%2C339678%2C494917%2C353592%2C571733%2C443354%2C576961%2C575872%2C581593%2C578596%2C518993%2C581827%2C495123&bug_id_type=anyexact&query_format=advanced

query: https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=anywordssubstr&field0-0-0=short_desc&bug_severity=critical&bug_severity=major&resolution=---&classification=Client%20Software&classification=Components&query_format=advanced&value1-0-0=restor%20start%20blank&type0-0-0=nowords&value0-0-0=crash%20hang%20hangs&component=Session%20Restore&field1-0-0=short_desc&product=Firefox

Note: Jakub has moved to Chrome
Keywords: dataloss
(In reply to comment #12)
> humph, isn't your issue bug bug 495123?  Or are you implying this bug is the
> exact same thing?

I'm not clear which of these two bugs is the one, so if you suggest it's better to work in the other one, that's fine.  I will note that I haven't experienced this for a while.

Comment 14

7 years ago
rob gone since comment 2 (but works for me) so => incomplete

(In reply to comment #13)
> (In reply to comment #12)
> > humph, isn't your issue bug bug 495123?  Or are you implying this bug is the
> > exact same thing?
> 
> I'm not clear which of these two bugs is the one, so if you suggest it's better
> to work in the other one, that's fine.  I will note that I haven't experienced
> this for a while.

humph, i'd say hang on to bug 495123
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
sounds good.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.