browser-chrome test harness should dump which test is starting.

VERIFIED DUPLICATE of bug 492467

Status

VERIFIED DUPLICATE of bug 492467
10 years ago
11 months ago

People

(Reporter: mak, Assigned: mak)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 obsolete attachments)

(Assignee)

Description

10 years ago
When we timeout we simply print that we have timed out, but it's hard to tell which test was running, we usually guess that from the dumps.

Let's suppose i have a test that does not dump anything just after a test that dumps something. If the second test timeout, looking at the log i will think the first test is timing out because is the only one that has dumped anything, when instead is the second one.

I think we could patch execTest this way:

  execTest: function Tester_execTest() {
    if (this.done) {
      this.finish();
      return;
    }

    // Move to the next test (or first test).
    this.step();
+    dump("EXECUTING TEST: " + this.currentTest.path + "\n");

that would tell us when a test starts, and in case of timeouts we will know for sure which test was running.

Does this make sense?
(Assignee)

Comment 1

10 years ago
Created attachment 379915 [details] [diff] [review]
patch v1.0
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #379915 - Flags: review?(gavin.sharp)
(Assignee)

Comment 2

10 years ago
Created attachment 379955 [details] [diff] [review]
dump also results on the fly

Alternatively, this will also dump each result as soon as it is created.

Bug 492467 will probably do something more than this, but this is safe and could be taken in the meanwhile.
The only problem could be that some test will generate a lot of output.
Attachment #379955 - Flags: review?(gavin.sharp)
Comment on attachment 379955 [details] [diff] [review]
dump also results on the fly

I'm not sure we want to do this without also fixing the browserTestFile log and htmlLog getters, since it will unnecessarily duplicate the output.
(Assignee)

Comment 4

10 years ago
Since Gavin wants to fix bug 492467, that will mostly provide the same (And probably more cleanup to the test harness), i'm duping to that.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492467
(Assignee)

Updated

10 years ago
Attachment #379915 - Attachment is obsolete: true
Attachment #379915 - Flags: review?(gavin.sharp)
(Assignee)

Updated

10 years ago
Attachment #379955 - Attachment is obsolete: true
Attachment #379955 - Flags: review?(gavin.sharp)
V.Duplicate
Status: RESOLVED → VERIFIED
Component: BrowserTest → Mochitest
Product: Testing → Testing
You need to log in before you can comment on or make changes to this bug.