Closed Bug 495175 Opened 15 years ago Closed 14 years ago

Download program does not insert the name of the file to be downloaded

Categories

(Firefox :: General, defect)

x86
Windows Vista
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: sabyers, Unassigned)

Details

(Whiteboard: [CLOSEME 2011-1-1])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)

The download program does not insert the name of the file to be downloaded. If you know the file name you can of course type it into the download dialogue, but often you do not know the file name or even the extension / type of file. I have to go to IE 8 to download usually.

Reproducible: Always

Steps to Reproduce:
1.select a file to download
2.Name of file is not "filled in" as it was in previous versions or in IE
3.
Actual Results:  
See above. Since I went to 3.5 Beta 4 I have NEVER been able to download like FF used to work. If I don't know what the extension of the file is - I get prompted to select a program to use to open the file, IF I did not know what the file extension is.

Expected Results:  
Name of the file selected to download
Have you tried in safe mode? http://support.mozilla.com/kb/Safe+Mode
I usually download without any problem with 3.5b4 on Vista.
I have had the same problem (missing file names) for the last 2 version releases of Firefox.  I also go IE 8.  The suggestion of going to "safe Mode" is a work around but does not solve the basic problem.
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Whiteboard: [CLOSEME 2011-1-1]
(In reply to comment #3)
> Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe
> mode? If not, please close. These links can help you in your testing.
> http://support.mozilla.com/kb/Safe+Mode
> http://support.mozilla.com/kb/Managing+profiles
> Also, please consider using the most recent Firefox 4 beta build, your bug may
> be resolved there.

Thanks for all the suggestions and help! The latest version of Firefox 3 works fine. I have tried Firefox 4 and really like it - but there are some add ons that I need that were not working with 4 when I tried it.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.