Mozilla Firefox 3.5 Beta 4 renders the font wrong. Looks like it renders it with "Subpixel Smoothing".

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
5 years ago

People

(Reporter: cryzed, Unassigned)

Tracking

({fonts})

3.6 Branch
x86
Linux
fonts
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10

When using Mozilla Firefox 3.5 Beta 4 with Ubuntu 9.04 the displaying and GUI font looks wrong. It looks as if it got rendered with "Subpixel Smoothing". For an illustration with further details take a look at the provided URL (http://img3.imagebanana.com/img/o5cuacw1/font_rendering.png)

Reproducible: Always

Steps to Reproduce:
1. Install Ubuntu 9.04 (Jaunty Jackalope)
2. Install Mozilla Firefox 3.5 Beta 4
3. Start Mozilla Firefox 3.5 Beta 4
Actual Results:  
The font looked wrong.

Expected Results:  
The font should have looked like the font in Mozilla Firefox 3.0.10.

I'm using Ubuntu 9.04 (Jaunty Jackalope) 32 bit. Additionally I've got an proprietary NVIDIA driver installed (Version 180.44). According to my NVIDIA X Server Settings I'm using a "Maxdata (Rogentech) B101710 (CRT-1 on GPU-0)" monitor model.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Updated

9 years ago
Keywords: fonts

Comment 1

9 years ago
Same bug here. The fonts in the chrome as well as in the web pages are affected with this.

I use Ubuntu 9.04 with an ATI graphics card. 

(this bug is the only thing that keeps me from using the beta, it's performance is way better than 3.0.10!!)
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]

Comment 3

7 years ago
The bug was still present in the firefox 3.6 release bundled with Ubuntu 10.04. I'll test the latest version (as well as 4.0beta) sometime soon, on a clean installed machine.

pretty much all ubuntu users use this dirty fix or something similar for over a year now: http://www.ubuntu-inside.me/2009/07/howto-fix-firefox-35s-font-hinting.html

Updated

7 years ago
Whiteboard: [CLOSEME 2011-2-25]
Version: 3.5 Branch → 3.6 Branch
Reporter, Firefox 4.0.1 has been released, and it features significant improvements over previous releases. Can you please update to Firefox 4.0.1 or later, and retest your bug? Please also create a fresh profile (
http://support.mozilla.com/kb/Managing+profiles), update your plugins (Flash, Java, Quicktime, Reader, etc) and update your graphics driver and Operating system to the latest versions available. 

If you still continue to see this issue, please comment. If you do not, please close this bug as RESOLVED > WORKSFORME

filter: prefirefox4uncobugs
no response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.