Closed Bug 495551 Opened 13 years ago Closed 13 years ago

hang on shutdown, zero cpu, few (1-2) imap connections - from imap url initiated during shutdown (modal alert from imap thread / proxy call to UI thread)

Categories

(MailNews Core :: Backend, defect)

x86
Windows Vista
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: wsmwk, Unassigned)

References

Details

(Keywords: hang, Whiteboard: [fixed by bug 494014])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #487965 +++
(which was a clone of Bug #485995)

last few comments from cloned bug, mainly bug 487965 comment 38
-------------------------------------------------------------------------
  (From update of attachment 379960 [details])
  stacks from visual studio
  hang in XP
  1 imap connection port 993
  16 threads
  20090527 nightly build

this is a completely different stack, and different issue, so the prev patch - (From update of attachment 378972 [details] [diff] [review]) - may have actually helped make this hang less common.

It looks to me like in the process of shutting down, someone tried to run an
imap url - it failed trying to read from the socket, and tried to put up an
alert about it, which requires proxying over to the ui thread. Meanwhile, the
ui thread is trying to shutdown the psm thread, which seems to be blocked for
some reason. 

If the IMAP thread didn't try to put up a modal alert, maybe we wouldn't have
this hang. But, it might be the case that simply trying to do a proxied call to
the ui thread is causing the hang, and we might still want to do something like
that in the case of a network error, just to mark the server as having had a
connection issue.

We're trying to get rid of the modal alerts. Until then, maybe we can be
smarter about not starting urls, or putting up the alerts if we've started the
shutdown process.
How frequently do you see this?  I don't suppose there are concrete steps to reproduce?  This might want to block Thunderbird 3, but it's a little hard to guess from just the information here.
In order:
- almost as easy to reproduce as bug 487965, but I have to go out of my way to do it
- iirc the steps are the same as bug 487965.  
- I don't think we'll know how pervasive the problem is until after b3 hits the masses. But even then we might not know the extent a) until people start using extensions in a big way and b) because more ppl need to be reporting their bugs (crap, I never thought I'd say we want more bug reports) by way of example http://forums.mozillazine.org/viewtopic.php?f=29&t=1118745
this should have been fixed by this patch https://bugzilla.mozilla.org/attachment.cgi?id=399804 in bug 494014.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Depends on: 494014
See Also: → 487965
Whiteboard: [fixed by bug 494014]
You need to log in before you can comment on or make changes to this bug.