The default bug view has changed. See this FAQ.

[10.5] Firefox crashing when switching paper sizes after preview [@ objc_msgSend] [@ PrintingCocoaPDEs@0x10686]

RESOLVED FIXED

Status

()

Core
Printing: Setup
--
critical
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: aaron.chmelik, Assigned: smichaud)

Tracking

({crash, relnote, verified1.9.2})

unspecified
x86
Mac OS X
crash, relnote, verified1.9.2
Points:
---
Bug Flags:
blocking1.9.1 -
wanted1.9.0.x +

Firefox Tracking Flags

(status1.9.2 .2-fixed, status1.9.1 .9-fixed)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10

When trying to preview a web page through firefox print menu in A4 paper size, firefox crashes intermittently. This is reproducable.

Reproducible: Sometimes

Steps to Reproduce:
1.bring up the firefox print menu
2.select "Paper Handling" submenu
3.check the "Scale to fit paper size" check box
4.Select "A4" paper size
5.Click "Preview"
6.Repeat. I have not had it crash the first time, only second or third, so this step is important!
Actual Results:  
After doing this a second or third time Firefox crashes

Expected Results:  
Preview window opens up with preview

Currently using Red Shift v3. Will uninstall and try again.
(Reporter)

Comment 1

8 years ago
Tested again with default theme, crashed after repeating steps four times.
Confirmed, bp-35182996-c1d7-48ce-a1a9-ee9402090530
Status: UNCONFIRMED → NEW
Component: General → Printing: Setup
Ever confirmed: true
Keywords: crash
Product: Firefox → Core
QA Contact: general → printing.setup
Summary: Firefox crashing when trying to preview for A4 paper size → Firefox crashing when trying to preview for A4 paper size [@ objc_msgSend] [@ PrintingCocoaPDEs@0x10686]
Created attachment 380616 [details]
stack
Created attachment 380620 [details]
Trunk stack with NSZombieEnabled=YES

-[PMPrintWindowController usingSuggestedPaper]: message sent to deallocated instance 0x1f282fa0
(Reporter)

Comment 5

8 years ago
Further testing has shown that Firefox does not crash during attempt to preview, but after selection of "A4" paper size.
This happens using  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090530 Shiretoko/3.5pre as well, nominating to get on the radar. As Aaron notes in Comment 5, the crash happens after you select the paper size and the preview, and then go back in and select a paper size again.

Here are my STR that seem to work every time:

1. Firefox | Print
2. "Paper Handling" submenu
3. Check the "Scale to fit paper size" check box
4. Select "A4" paper size
5. Click "Preview". Then close preview and go right back in to the Paper Handling dialog.
6. In my case I selected 5x7 and I crashed. I don't think it matters which option you select (A4, 5x7, etc)
Flags: blocking1.9.1?
Summary: Firefox crashing when trying to preview for A4 paper size [@ objc_msgSend] [@ PrintingCocoaPDEs@0x10686] → Firefox crashing when switching paper sizes after preview [@ objc_msgSend] [@ PrintingCocoaPDEs@0x10686]
Version: unspecified → 1.9.1 Branch
(Assignee)

Comment 7

8 years ago
I can also reproduce this, in recent Minefield, Shiretoko and
GranParadiso nightlies.

I can't repro in FF 2.0.0.20 or in Seamonkey 1.1.16 (both on the 1.8
branch), or in Camino (1.6.7 or a recent 1.9.0-branch nightly).

I suspect this is at least partly an Apple bug.  But FF probably did
something to trigger it.
(Assignee)

Updated

8 years ago
Version: 1.9.1 Branch → unspecified

Comment 8

8 years ago
I started to debug this, I'm reminded of bug 354110 (see bug 354110 comment #19). Bad mojo using a Carbon printing impl within a Cocoa application. The unfortunate difference with this bug is that we crash instead of just silently failing.

While this is a 100% reproducible crash I think it'll take us a little while to figure out what to do and users are unlikely to wander into these depths of the printing dialog so I recommend not blocking 1.9.1.
Agreed, not blocking, will relnote. I take it the workaround is: don't do that?
Flags: wanted1.9.1.x+
Flags: blocking1.9.1?
Flags: blocking1.9.1-
Keywords: relnote

Comment 10

8 years ago
Yup. In particular, avoid that popup menu for selecting page size. Opening that is what causes problems, print preview is fine.
Josh: Are you still investigating this? If not, can you find an owner for it?
Assignee: nobody → joshmoz
status1.9.1: --- → wanted
Flags: wanted1.9.1.x+ → wanted1.9.0.x+

Comment 12

8 years ago
I am not currently looking into this, we need to get rid of the Carbon printing dialog. I doubt there is much we can do about this without doing so. Moving printing to Cocoa is nearing the top of our priority list.
Assignee: joshmoz → nobody

Updated

8 years ago
Depends on: 456646
Whiteboard: [needs fix for bug 456646]
Markus: Is this bug fixed with your rewrite work?
Assignee: nobody → mstange
It's not. :(
Assignee: mstange → nobody
No longer depends on: 456646
Whiteboard: [needs fix for bug 456646]
> -[PMPrintWindowController usingSuggestedPaper]: message sent to deallocated
> instance 0x1f282fa0

There's a chance this was fixed by my patch for bug 396680.  It landed today and will appear in tomorrow's trunk (mozilla-central) nightly.  Please try it out once it appears.
Judging from the crash reports at http://crash-stats.mozilla.com, this bug is 10.5-only -- like bug 396680.
Summary: Firefox crashing when switching paper sizes after preview [@ objc_msgSend] [@ PrintingCocoaPDEs@0x10686] → [10.5] Firefox crashing when switching paper sizes after preview [@ objc_msgSend] [@ PrintingCocoaPDEs@0x10686]
This should be fixed by my patch for bug 396680 -- which has been on the trunk for a while, and just landed on the 1.9.2 and 1.9.1 branches.
Assignee: nobody → smichaud
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
status1.9.1: wanted → .9-fixed
status1.9.2: --- → .2-fixed
(Assignee)

Updated

7 years ago
Depends on: 396680
(In reply to comment #6)
> This happens using  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US;
> rv:1.9.1pre) Gecko/20090530 Shiretoko/3.5pre as well, nominating to get on the
> radar. As Aaron notes in Comment 5, the crash happens after you select the
> paper size and the preview, and then go back in and select a paper size again.
> 
> Here are my STR that seem to work every time:
> 
> 1. Firefox | Print
> 2. "Paper Handling" submenu
> 3. Check the "Scale to fit paper size" check box
> 4. Select "A4" paper size
> 5. Click "Preview". Then close preview and go right back in to the Paper
> Handling dialog.
> 6. In my case I selected 5x7 and I crashed. I don't think it matters which
> option you select (A4, 5x7, etc)

I can't reproduce this on pre-fix Firefox 3.5.8. During step 5, when preview comes up, it completely dismisses the Firefox print dialog and you have to start over after quitting preview. Is this 10.5 only? Marcia, can you verify this bug is fixed on Firefox 3.5.9 and 3.6.2 candidate builds?
Verified fixed on the 1.9.2 branch using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2. I crash easily using the 3.6 builds and following the STR in Comment 18.

I believe this bug is 10.5 only but I can check 3.5.x at a later date. Comment 16 indicates the crash data was showing this to be 10.5 only.
Keywords: verified1.9.2
Crash Signature: [@ objc_msgSend] [@ PrintingCocoaPDEs@0x10686]
You need to log in before you can comment on or make changes to this bug.