If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

navigator.cookieEnabled is not set properly when cookies are globally blocked

RESOLVED DUPLICATE of bug 578534

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 578534
8 years ago
5 years ago

People

(Reporter: misc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0 "6x9=54"
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

When I block cookies globally and enable them for specific sites, navigator.cookieEnabled is still false for those sites.

This is a real problem for sites that detect cookies via navigator.cookieEnabled and then display a nag screen if they're disabled, since it can only be worked around by accepting all cookies.

Reproducible: Always

Steps to Reproduce:
1. Disable cookies globally.
2. Visit the URL I provided.
3. Enable cookies for lunboks.bplaced.net.
4. Reload.
Actual Results:  
"Cookies are disabled.
document.cookie is 'testcookie=testvalue'."

Expected Results:  
"Cookies are enabled.
document.cookie is 'testcookie=testvalue'."

Updated

8 years ago
Component: General → DOM: Mozilla Extensions
Product: Firefox → Core
QA Contact: general → general
(Reporter)

Comment 1

8 years ago
Well, what now.

I've filed this bug 4 months ago, we've gone from Firefox 3 to 3.5, and this dumb behavior is still present. Anyone wanna at least confirm it, maybe?!

Comment 2

7 years ago
This is a dupe of Bug 230350
Have a look there if you totally want to loose faith in this bugzilla.

I would have actually confirmed and marked this bug a dupe, but I am not allowed to.
And I just spent quite a lot of time trying to find out *why* I am not allowed.
(I am supposed to do some other stuff first, and then I have to mail a guy named gerv - ain't that obvious?)
*sigh*

Comment 3

6 years ago
Thanks to Sindre Dammann, Brendan Eich and Boris Zbarsky, this bug has been fixed in tomorrow's nightlies and should make it into Firefox 8 (should be released in November).

Thanks for reporting.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578534
(Assignee)

Updated

5 years ago
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.