Closed Bug 495898 Opened 11 years ago Closed 11 years ago

Fast Dial gives javascript error; breaks places.sqlite

Categories

(Firefox :: Bookmarks & History, defect, critical)

3.5 Branch
x86
Windows Vista
defect
Not set
critical

Tracking

()

RESOLVED INVALID

People

(Reporter: GoNavyMikeAsbell, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 (.NET CLR 3.5.30729)
Build Identifier: Firefox/3.5b4

Fast Dial constantly gives me javascript error now that I've switched to the 3.5b4  I've tried to reload and even redownload the 3.0 version of firefox but still get the javascript error.  If I tell it to stop script, it gives me a blank page... if I say continue, it takes a few times of saying continue then it will go to the fast dial bookmark page but with bogus bookmarks that seem to go on forever.  Please help me get back my older Firefox w/fast dial.  My memory's not the best and the Fast Dial with paste email is like a God send to me.

Reproducible: Always

Steps to Reproduce:
1.Start up Firefox w/fast dial.
2.
3.
Actual Results:  
I just explained it up above.  (Sadness)(Disappointment)

Expected Results:  
When I start firefox I used to get my fast dial right away and would begin surfing my bookmarks right away.  (Happiness)

I can't imagine that I'm the only one with this problem.  Am I?
I can indeed reproduce this with the latest trunk nightly build on Windows XP. This extension is not compatible anymore, and what's worse, it can't work together anymore with places.sqlite (the file where your bookmarks and history are stored). The author of the extension should fix the problem, and you can't use Firefox 3.5 beta anymore before this problem is fixed.

I could solve the problem by deleting the file places.sqlite in my profile. Then it imported automatically a bookmarks backup. Deleting places.sqlite will make you lose your history.

See http://support.mozilla.com/en-US/kb/Profiles for profile info.
Component: Extension Compatibility → Places
QA Contact: extension.compatibility → places
Version: unspecified → 3.5 Branch
Please contact the add-on author.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → INVALID
This is a fairly popular add-on, so if it's actually damaging the places.sqlite file then I think that warrants tracking here. CCing author.

Telega: Can you please investigate this and change your listed compatibility range via the AMO developer control panel ASAP? Would like to prevent others from hitting this until you can provide a fix.

(current Fast Dial version is still 2.22b, for the record)
Summary: Fast Dial gives javascript error. → Fast Dial gives javascript error; breaks places.sqlite
I have tried the following:
- Created a new profile with Firefox 3.0.0.8, installed Fast Dial 2.22b, added a bookmark into it.
- Run Firefox 3.5b4 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4) on the same profile. It ran without error. Fast Dial executed successfully.

What version of Firefox did you run before the update?
Maybe you could provide me with places.sqlite & prefs.js which causes Fast Dial to hang?
I think the problem is about places.sqlite files with already errors or imperfections in them.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
I have corrected this issue by doing the following.

1. Went to my last profile that was working correctly
2. Copied the places.sqlite file
3. Created a new profile
4. In the new profile I changed the places.sqlite file to places.sqlite_old
5. Pasted the places.sqlite file from my previous profile

Once I started FF it loaded all of my bookmarks. So far no issues.
I'm running a Win7 x64 with Firefox 3.6 installed.
Well, when I select an .jpg(or any other file tipe) to set as Fast Dial's wallpaper it acts like everything is fine, but the image just don't show up.
I did exactly the samething on my notebook with Windows XP Pro x 32 and it worked perfectly.
I have no idea what's happening here, but it really makes me sad, I removed my old Speed Dial AddOn to instal Fast Dial only because of the wallpaper capability and it doesn't work.
sorry, you should contact extension's author.
You need to log in before you can comment on or make changes to this bug.