Closed Bug 496198 Opened 12 years ago Closed 11 years ago

about:plugins lies when all plugins are disabled

Categories

(Core :: Plug-ins, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla1.9.3a1

People

(Reporter: u88484, Assigned: wesongathedeveloper)

References

Details

Attachments

(1 file, 1 obsolete file)

about:plugins lies when all plugins have been disabled.  about:plugins tells you, "No plugins are installed" when in fact there are plugins installed but they are just disabled.

STR: 
1) Go to tools -> Add-ons, Plugins tab
2) Disable all plugins
2) Type about:plugins in the location bar, hit enter

about:plugins should tell you that all plugins have been disabled and tell the user how to enable plugins either by explanation or providing a link that opens the add-ons manager with the plugins tab focused.
about:plugins just uses navigator.plugins, which isn't populated when plugins are disabled. We could make the page privileged and have it check the actual state, but I'm not sure that's worth the effort.
Component: XUL Widgets → Plug-ins
Product: Toolkit → Core
QA Contact: xul.widgets → plugins
Just change the wording to "No active plugins found"
Duplicate of this bug: 498125
Attached patch Patch (obsolete) — Splinter Review
Assignee: nobody → wesongathedeveloper
Status: NEW → ASSIGNED
Attachment #421956 - Flags: review?(joshmoz)
Comment on attachment 421956 [details] [diff] [review]
Patch

+nopluginsareinstalled_label=No active plugins found

I think "enabled" is a better word than "active", and we might as well change the name of the label since that is also incorrect.
Attachment #421956 - Flags: review?(joshmoz) → review-
Attached patch PatchSplinter Review
Attachment #421956 - Attachment is obsolete: true
Attachment #422124 - Flags: review?(joshmoz)
Attachment #422124 - Flags: review?(joshmoz) → review+
Keywords: checkin-needed
Doesn't this need ui review?
Keywords: checkin-needed
Attachment #422124 - Flags: ui-review?(benjamin)
bsmedberg doesn't really do UI reviews. You should probably ask faaborg instead.

("No enabled plugins found" does seem a bit awkward to me, though I'm not sure what would be better)
Attachment #422124 - Flags: ui-review?(benjamin) → ui-review?(faaborg)
Attachment #422124 - Flags: ui-review?(faaborg) → ui-review+
We should probably file a follow up but so that about:plugins follows the same type of general visual design as other UI in the content area, but not a high priority since this isn't meant to be used by mainstream users.
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/11180eb153e1
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Flags: in-testsuite-
Keywords: checkin-needed
OS: Windows Vista → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a1
Version: unspecified → Trunk
Verified fixed: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100124 Minefield/3.7a1pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.