Last Comment Bug 496207 - Workaround zombie firefox.exe process during install
: Workaround zombie firefox.exe process during install
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Installer (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal with 4 votes (vote)
: ---
Assigned To: Robert Strong [:rstrong] (use needinfo to contact me)
:
: Matt Howell [:mhowell]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-03 14:50 PDT by Robert Strong [:rstrong] (use needinfo to contact me)
Modified: 2014-03-20 21:49 PDT (History)
21 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Robert Strong [:rstrong] (use needinfo to contact me) 2009-06-03 14:50:56 PDT
Currently if there is a zombie firefox.exe process with a registered dde server the installer will not allow the user to install until the process has exited or more likely has been killed.

We could work around this by only prompting the user to close the app once and then if the app is still in use just require a reboot to complete the installation.
Comment 1 Jesse Ruderman 2009-08-29 12:21:41 PDT
Could the installer try to kill the process itself?
Comment 2 Robert Strong [:rstrong] (use needinfo to contact me) 2009-08-30 00:23:12 PDT
We used to do that and it turned into dataloss bugs. As a workaround for the installer in regards to Firefox not shutting down completely I am planning on warning once and then if the process is still present requiring an OS restart to finish the install by replacing the files that were in use.
Comment 3 Jesse Ruderman 2009-08-30 00:27:00 PDT
Why would a kill from the installer cause dataloss bugs and a kill from OS shutdown not?
Comment 4 Robert Strong [:rstrong] (use needinfo to contact me) 2009-08-30 00:48:37 PDT
The OS typically does not kill the firefox.exe process. Apps have the ability to reply back to the shutdown windows message from the OS that they aren't ready to shutdown and there is also a timeout during shutdown after which Windows will kill an app that doesn't respond. What we are trying to workaround here is when Firefox is a zombie process where the only solution is to kill or require a reboot after completing the install. There is also the condition where a user doesn't realize Firefox is running and they have form data in a tab. Killing the process in this case causes dataloss and there have been bugs filed for this in the past which is why mconnor and I chose the current behavior where the installer never kills firefox.exe and instead prompts the user to close Firefox. With the number of users running Firefox on Windows this is a significant number of users though it is an extremely small percentage of the user base. The better solution would be to solve the zombie process problem though it doesn't appear that anyone has a firm understanding as to why that is happening plus our add-on / plugin / etc. story make it extremely unlikely that it would be solved entirely at present IMO though that may change in the future.
Comment 5 Jesse Ruderman 2009-08-30 01:03:00 PDT
If I understand correctly, your answer to comment 2 is "Because maybe the existing process isn't a zombie, just a Firefox window the user forgot about".  In that case, focusing Firefox would be more helpful than prompting the user to restart Windows.
Comment 6 Robert Strong [:rstrong] (use needinfo to contact me) 2009-08-30 01:17:08 PDT
That is by no means what we do now or what we would do in the future. We already prompt the user to close Firefox and we would continue to do so as I already stated. Once this bug is fixed the user would be prompted one time and if the process is still present the OS would need to be restarted to complete the install.

There are no unique Window ID's besides the message window for Firefox so it is not possible to accurately just activate the Firefox window... so, if there are any other Mozilla processes running we would activate the wrong window. I do think it would be good to be able to accurately identify the Window for a specific Firefox process but the widget code would need to have this enhancement before the installer would be able to use it.
Comment 7 Robert Strong [:rstrong] (use needinfo to contact me) 2009-08-30 01:20:01 PDT
btw: I had a discussion about unique windows on Windows with both Darin and bsmedberg about 3 years ago... there aren't clean solutions to this but we could hack around it and be even more different than most apps on Windows.
Comment 8 alanjstr 2009-09-04 06:49:13 PDT
This bug sounds like it would be closely tied to bug 490379.
Comment 9 Robert Strong [:rstrong] (use needinfo to contact me) 2009-09-04 12:36:47 PDT
It is similar in many ways except this is for the NSIS installer which is entirely different code
Comment 10 u295173 2010-02-10 05:03:41 PST
The zombie process is not only a problem during installation - its quite annoying all the time when you want to start Firefox and it is already running in the background! And non-tech-savvy users do not know how to kill a process.
Comment 11 Robert Strong [:rstrong] (use needinfo to contact me) 2010-02-10 11:26:59 PST
Agreed. This bug is specifically about working around that issue for the installer since no one (including myself) has been able to understand / fix the cause of the zombie process which I believe is an already filed bug.
Comment 12 Robert Strong [:rstrong] (use needinfo to contact me) 2010-06-19 20:17:48 PDT
I'm going to take care of this in bug 367539
Comment 13 Robert Strong [:rstrong] (use needinfo to contact me) 2010-06-21 23:49:27 PDT
fyi: changed my mind about taking care of this in Bug 367539 since that bug is already complicated enough as is.
Comment 14 Robert Strong [:rstrong] (use needinfo to contact me) 2014-03-20 13:28:16 PDT
This is fixed in the stub installer so wontfixing.

Note You need to log in before you can comment on or make changes to this bug.