Closed Bug 496372 Opened 11 years ago Closed 11 years ago

[silme] Provide Silme EntityList of untranslated strings in a package

Categories

(Mozilla Localizations :: Infrastructure, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sethb, Unassigned)

References

()

Details

This feature request would provide entity lists of untranslated strings to localizers for quick translation if the localizer has to work quickly/offline, but doesn't have time to commit translations.  

Use case:  Silme generates EntityList of only the untranslated strings.  Localizer translates and resend translated strings in EntityList with request for review and then checkin.

When I read this documentation: 

http://wiki.braniecki.net/Silme:Tutorial:Entity#EntityList

It seems that Entity List will generate a list of all entities, but cannot be simplified to only untranslated entities.
Duplicate of this bug: 496373
elistdiff = elist1.diff(elist2)

for entity in elistdiff.get_entities(type='removed'):
  print entity

will give you just untranslated entities from the diff between two entity lists.

Is that what you were looking for?

P.S. The "removed" here is because the entity exists in elist1, but does not exist in elist2. The nomenclature we use ("added","modified","removed") is not the same as localization tools should (respectively: "obsolete", "modified", "missing") but is much more natural on the code level.
Status: NEW → ASSIGNED
(In reply to comment #2)
> elistdiff = elist1.diff(elist2)
> 
> for entity in elistdiff.get_entities(type='removed'):
>   print entity
> 
> will give you just untranslated entities from the diff between two entity
> lists.
> 
> Is that what you were looking for?

I think that is it.  Potential use case that this would solve for me:  I want to send a package of just untranslated strings to a localizer as an attached .zip.  It looks like this does the trick.  If you agree, please resolve the bug as fixed/duplicate.
I don't know if this is this bug or another that Seth filed (too many flying by).

What I'm interested in is an exchange format that allows me to paste a single text on pastebin.m.o, and to get the translated strings back to import into the localization as a second step.

Zip is too deep already for that.
yes. you just need to create a way to write the list into a file (possibly in some format ;)).

But basically the example I gave in Comment 2 is the core of what you need to get untranslated strings into a form which you can send to a localizer and ask him to provide localization.

We could even gather missing entities from many files and create a single file to send it to localizer.

Pike: the bug you're looking for is bug 496382. :)
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Gandalf: is this really FIXED?

(In reply to comment #5)
> We could even gather missing entities from many files and create a single file
> to send it to localizer.

That's in fact what I'm doing with my TLT tool for years now :)
If I'd only have time to rewrite TLT, based on Silme... But still no time for that in the near future :(

Basically, we'd need a script that'd save all untranslated entities to one file (for TLT I'm using such a format:

pl•downloadmanager.properties•paused•J•Paused•Zatrzymano•
pl•downloadmanager.properties•percentFormat•J•%1$S%%•%1$S%%• LOCALIZATION NOTE (percentFormat): %1$S is download percent

where the second entity value is the localized string, and the first the en-US)
and a script that'd merge the entities back.
according to my best knowledge it's fixed. :)

I encourage you to rewrite your write such script and I recommend adding silme.format.tlt.Serializer and Parser for what you need :)
(In reply to comment #7)
> I encourage you to rewrite your write such script and I recommend adding
> silme.format.tlt.Serializer and Parser for what you need :)

That's exactly what I plan :)
You need to log in before you can comment on or make changes to this bug.