TM: 3x performance loss with JIT on Ball Pool demo.

RESOLVED DUPLICATE of bug 479090

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 479090
9 years ago
9 years ago

People

(Reporter: Sylvain Pasche, Unassigned)

Tracking

({perf, regression})

Trunk
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
I noticed this on this demo:
http://mrdoob.com/projects/chromeexperiments/ball_pool/

Try to click and drag in the window to add some balls. When the screen is nearly filled, the demo gets very sluggish.
I've modified this demo to remove all drawing operations/randomness in order to get some numbers. The following url runs 100 iterations in a 800x600 pool with 100 balls without drawing and reports the time it takes:
http://www.spasche.net/files/testcases/ball_pool/?iterations=100&balls=100&norand=1&nopaint=1

Fx 3.0: 6.5
Fx 3.6, JIT off: 5.5
Fx 3.6, JIT on: 16.75 (3x slower than non JIT)

And how others are doing:
Opera 10 beta: 4.8
Safari 4: 3.0
Chrome 3: 1.5

That demo is using the Box2DJS library (http://box2d-js.sourceforge.net/).

I'll try to reduce the testcase when I have a chance.
(Reporter)

Comment 2

9 years ago
yeah that should be the same issue. The same library is used and the demo just calls into it.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 479090
You need to log in before you can comment on or make changes to this bug.