TM: ecma/Expressions/11.4.8.js - FAIL

VERIFIED FIXED

Status

()

Core
JavaScript Engine
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: bc, Unassigned)

Tracking

({regression, testcase, verified1.9.1})

Trunk
x86
Mac OS X
regression, testcase, verified1.9.1
Points:
---
Bug Flags:
blocking1.9.1 +
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

jit, browser only so far on mac. my builds are in flux and I can't check other branches yet.

http://test.bclary.com/tests/mozilla.org/js/js-test-driver-standards.html?test=ecma%2FExpressions%2F11.4.8.js;language=type;text/javascript;jit

~-1 = -16384  FAILED! 0
~-2 = 1   PASSED!
~-4 = -16384  FAILED! 3
~-8 = -16384  FAILED! 7
~-16 = -16384  FAILED! 15
~-32 = -16384  FAILED! 31
~-64 = -16384  FAILED! 63
~-128 = -16384  FAILED! 127
~-256 = -16384  FAILED! 255
~-512 = -16384  FAILED! 511
~-1024 = -16384  FAILED! 1023
~-2048 = -16384  FAILED! 2047
~-4096 = -16384  FAILED! 4095
~-8192 = -16384  FAILED! 8191
~-16384 = -16384  FAILED! 16383
~-32768 = -16384  FAILED! 32767
~-65536 = -16384  FAILED! 65535
~-131072 = -16384  FAILED! 131071
~-262144 = -16384  FAILED! 262143
~-524288 = -16383  FAILED! 524287
~-1048576 = -16381  FAILED! 1048575
~-2097152 = -16377  FAILED! 2097151
~-4194304 = -16369  FAILED! 4194303
~-8388608 = -16353  FAILED! 8388607
~-16777216 = -16321  FAILED! 16777215
~-33554432 = -16257  FAILED! 33554431
~-67108864 = -16129  FAILED! 67108863
~-134217728 = -15873  FAILED! 134217727
~-268435456 = -15361  FAILED! 268435455
~-536870912 = -14337  FAILED! 536870911
~-1073741824 = -12289  FAILED! 1073741823
~-2147483648 = -8193  FAILED! 2147483647
Flags: in-testsuite+
sayrer says this is evident on 1.9.1 as well.
Flags: blocking1.9.1?
(In reply to comment #2)
> gal, backing out http://hg.mozilla.org/tracemonkey/rev/ea72bb61b701 did not fix
> it.

I meant to say, backing that out didn't show the problem. bisection on 1.9.1 coming up.

Updated

9 years ago
Flags: blocking1.9.1? → blocking1.9.1+
Bug 495958 claims that a follow-up patch was missed; any chance it's that which caused this regression?

Bob: which branches are you seeing this on?

Comment 6

9 years ago
This patch was supposed to be backed out. Updating the bug.

Comment 7

9 years ago
TM tip does not show this regression.

Ok, so here is the story:

I backed out the patch along with a fix for something else the patch regressed and I didn't update the 2 bugs when I did so. We re-patched one of the bugs. The other is no longer needed and WONTFIX. It looks like the backout didn't make it to branch.

I re-opened the 2 bugs to make sure they get landed on branch.

http://hg.mozilla.org/tracemonkey/rev/47ae3c6dcf9e
http://hg.mozilla.org/tracemonkey/rev/f5e133f0c132
(In reply to comment #5)
> Bug 495958 claims that a follow-up patch was missed; any chance it's that which
> caused this regression?
> 
> Bob: which branches are you seeing this on?

1.9.1 and 1.9.2 but not tracemonkey.

Comment 9

9 years ago
this passes for me with

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090605 Minefield/3.6a1pre

Comment 10

9 years ago
Also fixed in latest 1.9.1 build, with Gal's patches.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Keywords: fixed1.9.1
Resolution: WORKSFORME → FIXED
v 1.9.3, 1.9.2, 1.9.1
Status: RESOLVED → VERIFIED
Keywords: fixed1.9.1 → verified1.9.1
You need to log in before you can comment on or make changes to this bug.