Closed Bug 496533 Opened 11 years ago Closed 3 years ago

XMLHttpRequest should have some way to get and remove partial .textContent

Categories

(Core :: DOM: Core & HTML, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 687087

People

(Reporter: smaug, Unassigned)

Details

It would be useful if there was some way to get and remove partial .textContent data. This way XHR wouldn't need to keep all the data in memory and
there was no need to copy so much data from XHR to JS.

Maybe something like this:
interface nsIXMLHttpRequest
{
...
  DOMString getTextContent(unsigned long long offset, unsigned long long length,
                           boolean remove /*if true, the data is removed from the internal buffer*/);
  readonly attribute unsigned long long textContentLength;
};

Maybe something similar for .responseBody.
See http://www.bluishcoder.co.nz/2009/06/reading-ogg-files-with-javascript.html
I need to send this to webapps wg
Component: DOM: Mozilla Extensions → DOM
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 687087
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.