Make check in js/src should run the js test suite

RESOLVED DUPLICATE of bug 469718

Status

()

P1
normal
RESOLVED DUPLICATE of bug 469718
9 years ago
9 years ago

People

(Reporter: jorendorff, Unassigned)

Tracking

Other Branch
Points:
---
Bug Flags:
blocking1.9.2 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
`make check` in an objdir for js/src should run the regression test suite in js/tests.

The catch: Right now, given a snapshot of the trunk, you can't just run all the tests and tell if anything is wrong. You need either a baseline js shell (as in bug 478437 comment 30), or an externally maintained list of expected failures (as in <http://hg.mozilla.org/users/jorendorff_mozilla.com/scripts/file/3eda1f592c0c/js-check>). Either way you need a script that isn't checked in.

(Why do we have tests that are expected to fail?  To reduce the cost of maintenance, the whole js/tests directory is kept identical in all branches.  Some tests pass in some branches and not in others.  Some tests only pass in Rhino.  Some tests only pass if LiveConnect is present.  Having expected failures is teh lame, but this bug should not block on that.)

(Related: Bug 473989 asks for "make check" to run trace-test.js.  It can do both.)
Flags: blocking1.9.2?

Updated

9 years ago
Flags: blocking1.9.2? → blocking1.9.2+

Comment 1

9 years ago
Create a list that excludes liveconnect and check it in?
(In reply to comment #0)

> (Related: Bug 473989 asks for "make check" to run trace-test.js.  It can do
> both.)

Yes please. And v8 and ss. And as many other suites as we can dig up. Many of the compute-intensive demos we've seen on the web are good candidates. I have a list that I keep meaning to convert to shell cases.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 469718

Updated

9 years ago
Priority: -- → P1
You need to log in before you can comment on or make changes to this bug.