Closed Bug 496678 Opened 12 years ago Closed 12 years ago

Crash on notification window close [@ nsAlertsIconListener::SendClosed()]

Categories

(Firefox :: General, defect)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 530921

People

(Reporter: jdm, Unassigned)

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090529 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090529 Minefield/3.6a1pre

This has been the top crasher on Linux for 3.6a1 for the past three weeks, so I'm a little surprised that I can't find any other bugs filed about it.   This is reproducible with any file that I download - as soon as the "File has finished downloading" notification window tries to close (either timed or intentionally), Minefield crashes hard.

Reproducible: Always

Steps to Reproduce:
1. Download a file
2. Wait for the notification to appear
3. Close the notification
Actual Results:  
Minefield segfaults, crash reporter appears.

Expected Results:  
Notification window disappears, Minefield continues to hum along.

From the crash reports, it looks like this is happening regardless of distro (I'm seeing Ubuntu, Fedora 10 (mine), Arch, and more).
Can you give a stacktrace please? https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
Keywords: crash
Version: unspecified → Trunk
Well, as I mentioned, this is the top linux crashes, and every stack trace I've looked at looks the same.  However, one example of many:

http://crash-stats.mozilla.com/report/index/694c28ac-7423-4301-a767-c5a1a2090605
Does it happen when you create a new profile?
Yes, and in safe mode as well.
For the record, I upgraded to Fedora 11 and the problem is no longer reproducible.
Well, maybe something changed in ff or fedora, but WFM for now.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Judging by the stack trace, it's possible the upgrade to Gnome 2.26 that made a difference.
May someone reopen this one?

I'm still seeing this bug a lot, eg:
http://crash-stats.mozilla.com/report/index/a7a2daf5-d29a-4d45-b3b8-b9a352091021?p=1

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20091021 Minefield/3.7a1pre on Ubuntu 9.04

I reproduce almost every time with the notification/tooltip from my weatherfoxie extension: https://addons.mozilla.org/en-US/firefox/addon/4896
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 516124
Duplicate of bug: 530921
Crash Signature: [@ nsAlertsIconListener::SendClosed()]
You need to log in before you can comment on or make changes to this bug.