error 0x80004005 occurs on 1st startup

RESOLVED DUPLICATE of bug 470430

Status

Calendar
General
RESOLVED DUPLICATE of bug 470430
9 years ago
9 years ago

People

(Reporter: Darlene Ford, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/530.5 (KHTML, like Gecko) Chrome/2.0.172.30 Safari/530.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18pre) Gecko/20080917 Sunbird/0.9

popup says

An error was encountered preparing the calendar located at moz-profile-calendar:// for use. It will not be available

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageConnection.executeSimpleSQL]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calStorageCalendarModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calStorageCalendar.js :: addColumn :: line 898"  data: no]

error console says

Error: Upgrade failed! DB Error: duplicate column name: is_organizer
Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageConnection.executeSimpleSQL]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calStorageCalendarModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calStorageCalendar.js :: addColumn :: line 898"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calStorageCalendarModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calStorageCalendar.js
Line: 898
Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageConnection.executeSimpleSQL]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calStorageCalendarModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calStorageCalendar.js :: addColumn :: line 898"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calStorageCalendarModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calStorageCalendar.js
Line: 898
Error: Assert failed: An error was encountered preparing the calendar located at moz-profile-calendar:// for use. It will not be available.
1: [file:///C:/Program%20Files/Mozilla%20Sunbird/components/calItemModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calUtils.js:1004] ASSERT
2: [file:///C:/Program%20Files/Mozilla%20Sunbird/components/calItemModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calCalendarManager.js:560] cmgr_createCalendar
3: [file:///C:/Program%20Files/Mozilla%20Sunbird/components/calItemModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calCalendarManager.js:708] cmgr_assureCache
4: [file:///C:/Program%20Files/Mozilla%20Sunbird/components/calItemModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calCalendarManager.js:684] cmgr_getCalendars
5: [null:0] null

Source File: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calItemModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calUtils.js
Line: 1009

Error: Upgrade failed! DB Error: duplicate column name: is_organizer

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageConnection.executeSimpleSQL]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calStorageCalendarModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calStorageCalendar.js :: addColumn :: line 898"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calStorageCalendarModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calStorageCalendar.js
Line: 898

Error: Assert failed: An error was encountered preparing the calendar located at moz-profile-calendar:// for use. It will not be available.
1: [file:///C:/Program%20Files/Mozilla%20Sunbird/components/calItemModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calUtils.js:1004] ASSERT
2: [file:///C:/Program%20Files/Mozilla%20Sunbird/components/calItemModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calCalendarManager.js:560] cmgr_createCalendar
3: [null:0] null
4: [chrome://calendar/content/calendar-management.js:114] loadCalendarManager
5: [chrome://calendar/content/calendar-chrome-startup.js:43] commonInitCalendar

Source File: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calItemModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calUtils.js
Line: 1009

Error: calendar has no properties
Source File: file:///C:/Program%20Files/Mozilla%20Sunbird/components/calItemModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calCalendarManager.js
Line: 580

Error: uncaught exception: [Exception... "'[JavaScript Error: "calendar has no properties" {file: "file:///C:/Program%20Files/Mozilla%20Sunbird/components/calItemModule.js -> file:///C:/Program%20Files/Mozilla%20Sunbird/js/calCalendarManager.js" line: 580}]' when calling method: [calICalendarManager::registerCalendar]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://calendar/content/calendar-management.js :: loadCalendarManager :: line 116"  data: yes]

Error: calendar has no properties
Source File: chrome://calendar/content/calendar-task-editing.js
Line: 107






Reproducible: Always

Steps to Reproduce:
1.Download
2.install
3. start program - error appears immediately
4. close program, restart, same error
Actual Results:  
program starts with error messages

Expected Results:  
program starts without error messages

Windows XP SP3
Dvorak right hand keyboard map
(Reporter)

Comment 1

9 years ago
Immediately afterward tried file new calendar and got error

Error: this.treebox has no properties
Source File: chrome://calendar/content/calendar-management.js
Line: 324

looks like I'm dead in the water

any possible relation to previous Lightening problems?  https://bugzilla.mozilla.org/show_bug.cgi?id=492721
The error message "Upgrade failed! DB Error: duplicate column name: is_organizer" indicates that this is a duplicate of Bug 470430.

Did you used Sunbird in the past?

You could workaround the upgrade issue by removing your old Sunbird profile folder and its data. The folder is located at "%APPDATA%\Mozilla\Sunbird", e.g. "C:\Documents and Settings\<user name>\Application Data\Mozilla\Sunbird". Afterwards start Sunbird and let it create a new profile.
(Reporter)

Comment 3

9 years ago
Yes, you're right.  0.9 will at least start, and let me create calendars now that I have a brand-new profile.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 470430
You need to log in before you can comment on or make changes to this bug.