JavaScript Tests - run browser tests via file:

RESOLVED FIXED

Status

Testing
Sisyphus
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: bc, Assigned: bc)

Tracking

Trunk
x86
All
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Created attachment 382081 [details] [diff] [review]
patch

I finally looked into the problem with why the JavaScript Tests can't be run using file:. It appears that when using file: instead of http:; the jsTestDriverBrowserInit() function, which inserts the test scripts via document.write, the first document.written script is ignored which causes failures in cases where the subsuite's shell.js script is required.

For example:

file:///PathToRepo/js/tests/js-test-driver-standards.html?test=e4x%2FExpressions%2F11.2.2.js;language=type;text/javascript

If I insert a blank script prior to the first real script, it works. I tried simple tests cases but could not reproduce.

Blake, before I work around this, would you care to look?
(Assignee)

Updated

9 years ago
Blocks: 469718
(Assignee)

Comment 1

8 years ago
http://hg.mozilla.org/tracemonkey/rev/3c03e96d6910

/cvsroot/mozilla/js/tests/browser.js,v  <--  browser.js
new revision: 1.14; previous revision: 1.13
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.