Oracle documentation page rendered twice

RESOLVED WORKSFORME

Status

defect
--
minor
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: a9016009, Unassigned)

Tracking

Fennec 1.1

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs; rv:1.9.0.10) Gecko/2009042708 Firefox/3.0.10
Build Identifier: 

Content of a specific Oracle page (which includes lots of Javascript) is rendered twice in Fennec.

Reproducible: Always

Steps to Reproduce:
1. Go to the URL with Fennec 1.0 beta 1.
2. Scroll down.
3. Compare to Desktop Firefox 3 which renders the page correctly.
Actual Results:  
Content rendered twice.

Expected Results:  
Content rendered once.

Found while trying to reproduce https://bugs.maemo.org/show_bug.cgi?id=2036 (which is FIXED).
This is not really a redraw issues (?) but this have something to see with JS. If you disable JS in Fennec options the page is rendered properly.
Posted file minimal testcase
This testcase includes two <frameset>s:

<html>
  <head>
    <title>frames</title>
  </head>
  <frameset cols="30%,*">
    <frame src="data:text/plain,frame 1">
    <frame src="data:text/plain,frame 2">
  </frameset>
  <frameset cols="50%,*">
    <frame src="data:text/plain,frame 3">
    <frame src="data:text/plain,frame 4">
  </frameset>
</html>

When Gecko loads the file with the window size 640x480, both <frameset>s become 640x480 and the <html> becomes 640x960 (640x480 + 640x480). On Firefox, we can see only the first <frameset>. When we resize the whole window, each <frameset> are always resized to the same size of the window and the <html> becomes x2 height internally.

On Fennec, InputHandler or CanvasBrowser scrolls (pan) the screen based on the size of <html>. So, we unexpectedly see the second <frameset> only on Fennec. (see also but 458741)
s/but 458741/bug 458741/
Posted patch quick hackSplinter Review
Hack to show only the first <frameset>.
Comment on attachment 383172 [details] [diff] [review]
quick hack

The patch seems to create a file called "4a73f3e10e4a" instead of the intended "frameset.css"
Given that there's a quick work around for this issue attached to the bug already. This bug should be put out of UNCONFIRMED state and into new.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I was able to reproduce this in 1.9.2, but it is fixed in trunk (1.9.3).
Status: NEW → RESOLVED
Last Resolved: 9 years ago
OS: Linux → All
Hardware: x86 → All
Resolution: --- → WORKSFORME
Version: Trunk → 1.9.2 Branch
You need to log in before you can comment on or make changes to this bug.