Closed Bug 496981 Opened 12 years ago Closed 12 years ago

Debugger crashing on breakpoint

Categories

(Core :: JavaScript Engine, defect)

1.9.1 Branch
x86
macOS
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: rcampbell, Unassigned)

References

()

Details

(Keywords: crash, crashreportid)

Attachments

(2 files)

With Firebug 1.4b1 (or a31) installed,

1. go the URL above. (http://www.procreativeinc.com/golf_courses.aspx)
2. open Firebug and select the Script panel
3. Reload the page
4. from the scripts drop-down, select golf-courses.aspx.
5. on line 26, set a breakpoint.
6. reload the page again.

Page breaks as you would expect, but crashes after a couple of seconds.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090608 Shiretoko/3.5pre ID:20090608031104

http://crash-stats.mozilla.com/report/index/f28a77c6-f16e-49ee-a951-5fc6e2090608?p=1
Keywords: crash, crashreportid
can you reproduce on a current hourly, or on TM tip?
Attached file stack trace
reloading that URL with firebug enabled is producing:

Assertion failure: 0, at /Volumes/Data/MOZILLA-191/mozilla-1.9.1/js/jsd/jsd_scpt.c:828

see attached stack trace.
(reloading that URL with a debug-enabled build of Firefox 3.5pre, that is)
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090608 Shiretoko/3.5pre ID:20090608201035

built from:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/4578911cc143
That assertion looks like it's because bug 483847 never landed on the 1.9.1 branch.
testcase passes in m-c:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090608 Minefield/3.6a1pre ID:20090608031213

http://hg.mozilla.org/mozilla-central/rev/4f11e242a00e

Fails on latest tracemonkey build:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090608 Minefield/3.6a1pre ID:20090608031213

http://hg.mozilla.org/tracemonkey/rev/1f99f42b5382
Depends on: 483847
yeah, they broke our test case solidly. I'm going to see if I can extract enough of their code to recreate it and retest with the landed fix from bug 483847.
Attached file golf_courses.html
corrected test page
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
tonight's shiretoko fixes the problem in the attached testcase, (Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090610 Shiretoko/3.5pre).

verified test breaks on 3.5b99.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.