If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Duplication in a smart bookmark that queries most visited bookmarks

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Phil, Unassigned)

Tracking

3.5 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99 (.NET CLR 3.5.30729)

I have a smart bookmark set up to query my most visited bookmarked sites.  When I click on a site in the bookmark sidebar (or from the menu), the site loads then the smart bookmark expanded list is populated with multiple entries for the site.  This behavior did not occur in Firefox 3.0 or 3.5 Beta 4

Reproducible: Always

Steps to Reproduce:
1. Create a new bookmark with the following location information: place:queryType=0&sort=8&maxResults=10&onlyBookmarked=true

2. Open bookmark sidebar

3. Expand new smart bookmark

4. Click on link in expanded list to open site
Actual Results:  
Most of links in the list will change to a link to the site just opened.

Expected Results:  
Link list should remain mostly static, and there should never be duplicates.

I've posted before and after screenshots here:
http://pgilston.smugmug.com/gallery/8494329_svjZM/1/558866970_bS3ew
(Reporter)

Comment 1

8 years ago
I have no idea what is going on - I duplicated the bug several times an hour ago, but now it seems to have resolved itself on my computer.
could be related to bug 496542? sounds like some glitch with partitioning
(Reporter)

Comment 3

8 years ago
Thank you, Marco, that does sound like the same (or a very similar) bug.
in the event that it's not caused by the same problem, i'm going to make this bug dependent on bug 496542 instead of duping it. this will ensure this scenario doesn't slip through the cracks.
Depends on: 496542
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → 3.5 Branch
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think this is wfm, btw there is no address to reproduce it, so it's also partially incomplete.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.