consolodate xpfe/components shared libs

RESOLVED WONTFIX

Status

P3
normal
RESOLVED WONTFIX
19 years ago
5 years ago

People

(Reporter: jud, Assigned: alecf)

Tracking

({perf})

Trunk
Future
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
The xpfe/components shared libraries should be consolodated into a single shared 
lib in order to save on system overhead. ~32k bytes is used by the system on 
linux for each shared lib.

Comment 1

19 years ago
*** Bug 49713 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
Shouldn't the OS be Linux, then?
(Reporter)

Comment 3

19 years ago
windows benefits from it too.

Comment 4

18 years ago
nav triage team:

Doesn't mac already do this? At any rate, unless deemed necessary for embedding, 
not a beta1 stopper. Marking nsbeta1-
Keywords: nsbeta1-

Comment 5

18 years ago
Marking nsbeta1- bugs as future to get off the radar
Target Milestone: --- → Future

Updated

18 years ago
Blocks: 71874
Keywords: perf
(Reporter)

Comment 6

16 years ago
-> alec who's been gotten his head around lib consolodation more recently.
Assignee: law → alecf
Product: Core → Mozilla Application Suite

Comment 7

11 years ago
XPFE isn't used on trunk any more.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.