Status

www.mozilla.org
General
VERIFIED WONTFIX
9 years ago
5 years ago

People

(Reporter: rdoherty, Assigned: davedash)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 7 obsolete attachments)

(Reporter)

Description

9 years ago
Tracking creating of desktop Fennec homepage. PSD to come.
Created attachment 383772 [details] [diff] [review]
v1

images in following attachment
Attachment #383772 - Flags: review?(rdoherty)
Attachment #383772 - Attachment description: Initial attempt at home page → v1
Created attachment 383773 [details]
images

place in /img/mobile/
Some areas that might need work is the box that surrounds the main content... it's not flexible - I'm not sure what the best way to do that is.

The download button - I may have veered a bit from the rest of the site.  It also not a sprite, as I didn't know how in photoshop to create the "hover'd" version.

If you think those need to be fixed, then I am open to suggestions on how.
Created attachment 384516 [details] [diff] [review]
v2

patch -p1 and this will work :)
Attachment #383772 - Attachment is obsolete: true
Attachment #384516 - Flags: review?(rdoherty)
Attachment #383772 - Flags: review?(rdoherty)
(Reporter)

Comment 5

9 years ago
Comment on attachment 384516 [details] [diff] [review]
v2

Code looks pretty good. Glad that you created the subnav as a function.

I think we could increase the font sizes a bit in the main module. (I know I'm changing my mind about specific styles, but I think it would make it look a lot better)

The "Send Text" button font size looks too small.

The 2nd and 3rd bottom modules are missing their background images. Not sure if they were in the patch as binary? The font sizes seem too small also.

The bottom modules also have a large empty gap at the end, it looks like they are too narrow.
Attachment #384516 - Flags: review?(rdoherty) → review-
Created attachment 384734 [details] [diff] [review]
v3

Updates based on your suggestions.
Attachment #384516 - Attachment is obsolete: true
Attachment #384734 - Flags: review?(rdoherty)
Created attachment 384735 [details]
images v2
Attachment #383773 - Attachment is obsolete: true
(Reporter)

Updated

9 years ago
Attachment #384734 - Flags: review?(rdoherty) → review+
(Reporter)

Comment 8

9 years ago
Comment on attachment 384734 [details] [diff] [review]
v3

Looks much better now. I'm r+ it with just a few tiny tweaks to be made that can be added and committed.

The bottom module background isn't a gradient as it is in the PSD.

It also seems like the padding is off for the bottom modules. The last module's text touches the edge on the right.

The font color and size is different than the psd too. 

This is good to go once those small issues are fixed.
28335
4 files
16:57 - ddash@mozilla.com
[bug 497185] adjusted the bottom spiffies on the mobile page
A	/projects/mozilla.com/trunk/img/mobile/bottom-bg.png
D	/projects/mozilla.com/trunk/img/mobile/developers-wanted-box-bg.png
D	/projects/mozilla.com/trunk/img/mobile/video-tour.png
M	/projects/mozilla.com/trunk/style/tignish/mobile.css
28334
3 files
16:57 - ddash@mozilla.com
bug 497185 Made some font size adjustments per RD's comments
M	/projects/mozilla.com/trunk/en-US/mobile/index.html
A	/projects/mozilla.com/trunk/img/mobile/developers-wanted-box-bg.png
M	/projects/mozilla.com/trunk/style/tignish/mobile.css
28333
26 files
16:57 - ddash@mozilla.com
bug 497185 Home page changes
M	/projects/mozilla.com/trunk/en-US/mobile/index.html
A	/projects/mozilla.com/trunk/img/mobile/feature-box-background.png
A	/projects/mozilla.com/trunk/img/mobile/green-button-arrow.png
A	/projects/mozilla.com/trunk/img/mobile/img
A	/projects/mozilla.com/trunk/img/mobile/img/mobile
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/button-blue.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/button-green.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/download-background-phone.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/download-background.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/feature-box-background.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/green-button-arrow.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/icon-addons.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/icon-awesomebar.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/icon-phone.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/mobile-title.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/mobile-title2.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/mobile_256.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/mobile_64.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/mobile_video_thumb.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/right-arrow-divider.png
A	/projects/mozilla.com/trunk/img/mobile/img/mobile/video-tour.png
A	/projects/mozilla.com/trunk/img/mobile/right-arrow-divider.png
A	/projects/mozilla.com/trunk/img/mobile/video-tour.png
M	/projects/mozilla.com/trunk/includes/functions.inc.php
A	/projects/mozilla.com/trunk/js/mobile-desktop.js
M	/projects/mozilla.com/trunk/style/tignish/mobile.css
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Duplicate of this bug: 496665
Reopening since we redsigned some :)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 386406 [details] [diff] [review]
v4

This implements the new design.  Download.php does not go anywhere.
Attachment #384734 - Attachment is obsolete: true
Attachment #386406 - Flags: review?(rdoherty)
Created attachment 386408 [details]
images v3

These images go with v4
Attachment #384735 - Attachment is obsolete: true
What's the new design?  Do we have a mock for it?  Thanks!
Created attachment 386415 [details] [diff] [review]
v5

Fixed a typo from 500116
Attachment #386406 - Attachment is obsolete: true
Attachment #386415 - Flags: review?(rdoherty)
Attachment #386406 - Flags: review?(rdoherty)
Blocks: 500116
Blocks: 497194
Created attachment 386581 [details] [diff] [review]
v6

Verified that this patch worked by using:

patch -p1 -i $PATCH

Let me know if there's patching issues.
Attachment #386415 - Attachment is obsolete: true
Attachment #386581 - Flags: review?(rdoherty)
Attachment #386415 - Flags: review?(rdoherty)
(Reporter)

Comment 17

9 years ago
Created attachment 386594 [details]
New design
(Reporter)

Comment 18

9 years ago
Comment on attachment 386581 [details] [diff] [review]
v6

Overall, this looks really good.

A few minor issues that need to be fixed before committing, but it's fine otherwise.

There's a large gap above the text 'Choose from two...' that doesn't exist in the mockup.

Also missing the semicolon at the end of 'Choose from two download options'.

Choice #2 has Fennec misspelled. (Download Fenne to your computer)

Looking much better than the first design :)
Attachment #386581 - Flags: review?(rdoherty) → review+
awesomepants:~/Projects/Fennec/mozilla.com % git svn dcommitCommitting to https://svn.mozilla.org/projects/mozilla.com/trunk ...
        M       en-US/mobile/index.html
Committed r29302
        M       en-US/mobile/index.html
r29302 = 33e528ae78bce69540116c9862dcb91550366f96 (trunk)
No changes between current HEAD and refs/remotes/trunk
Resetting to the latest refs/remotes/trunk
en-US/mobile/index.html: locally modified
img/mobile/right-arrow-divider.png: locally modified
style/tignish/mobile.css: locally modified
        M       en-US/mobile/index.html
Committed r29303
        M       en-US/mobile/index.html
r29303 = 9121cb5eac0da54a9494c88c794c17b7a16da481 (trunk)
No changes between current HEAD and refs/remotes/trunk
Resetting to the latest refs/remotes/trunk
en-US/mobile/index.html: locally modified
img/mobile/right-arrow-divider.png: locally modified
style/tignish/mobile.css: locally modified
        D       img/mobile/right-arrow-divider.png
        M       en-US/mobile/index.html
        M       style/tignish/mobile.css
Committed r29304
        D       img/mobile/right-arrow-divider.png
        M       en-US/mobile/index.html
        M       style/tignish/mobile.css
r29304 = 41969cc15f9da33f50a0809ee501697836c5e0a7 (trunk)
No changes between current HEAD and refs/remotes/trunk
Resetting to the latest refs/remotes/trunk
en-US/mobile/index.html: locally modified
style/tignish/mobile.css: locally modified
        M       en-US/mobile/index.html
        A       img/mobile/green-button-arrow-down.png
        A       img/tignish/features/features-divider-horizontal.png
        M       style/tignish/mobile.css
Committed r29305
        A       img/mobile/green-button-arrow-down.png
        A       img/tignish/features/features-divider-horizontal.png
        M       en-US/mobile/index.html
        M       style/tignish/mobile.css
r29305 = 1d85bfc7b7321dd4635d199a9fe3b2f96dc8ae31 (trunk)
No changes between current HEAD and refs/remotes/trunk
Resetting to the latest refs/remotes/trunk
en-US/mobile/index.html: locally modified
style/tignish/mobile.css: locally modified
        M       en-US/mobile/index.html
Committed r29306
        M       en-US/mobile/index.html
r29306 = 4ea805ac74faf2e38b914dfcf8f37390bf62a4c1 (trunk)
No changes between current HEAD and refs/remotes/trunk
Resetting to the latest refs/remotes/trunk
en-US/mobile/index.html: locally modified
style/tignish/mobile.css: locally modified
        M       en-US/mobile/index.html
        M       style/tignish/mobile.css
Committed r29307
        M       en-US/mobile/index.html
        M       style/tignish/mobile.css
r29307 = 676696b90e03eaf1deedb10cdf3bb70918bd0a3f (trunk)
No changes between current HEAD and refs/remotes/trunk
Resetting to the latest refs/remotes/trunk
I suspect Stephen is going to want things aligned with other things ;)
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
Blocks: 502088
the customization link is wrong  it currently directs to https://www-trunk.stage.mozilla.com/en-UShttp://addons.mozilla.org/fennec/ 
it should be http://addons.mozilla.org/fennec/ 

http://screencast.com/t/scIpCFvyKn

The developers link is also broken.
the customization link is wrong  it currently directs to
https://www-trunk.stage.mozilla.com/en-UShttp://addons.mozilla.org/fennec/ 
it should be http://addons.mozilla.org/fennec/

The developers link is also broken.

i have attached a screencast
http://screencast.com/t/9kFqpEkJt
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → WONTFIX
This is tracked in other bugs (specifically, bug 513306).
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.