pressing spacebar scrolls down even if focus is on checkbox

VERIFIED DUPLICATE of bug 3999

Status

()

Core
Event Handling
P3
normal
VERIFIED DUPLICATE of bug 3999
19 years ago
19 years ago

People

(Reporter: cpratt, Assigned: joki (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
if you go to the my yahoo page at the above url, do this to see what i'm talking
about:

- click into the yahoo! id field
- press tab twice to change focus on the 'remember my id' checkbox
- press the spacebar

result: the whole page scrolls down. the checkbox is now off of the screen

expected result: the page does not scroll down. the page should only scroll down
if the focus is not on a form element, but in the general page itself (this is
nav 4.51 behavior).
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

19 years ago
*** This bug has been marked as a duplicate of 3999 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

19 years ago
"it scrolls whenever an event passes through a
scrollframe, even if that event is destined for text fields or some such"

- right you are. this is a dupe.
You need to log in before you can comment on or make changes to this bug.