Empty submenus display as tiny box

VERIFIED DUPLICATE of bug 33723

Status

()

P3
normal
VERIFIED DUPLICATE of bug 33723
19 years ago
11 years ago

People

(Reporter: dean_tessman, Assigned: mikepinkerton)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If you have, for example, a submenu in bookmarks that contains no items, the 
popup menu that opens is a very tiny box, probably 2x2 pixels.  It should either 
not pop anything out or, and this is my preference, pop out a single-item menu 
that has a disabled "(Empty)" item in it.  The latter seems to be the Windows 
standard for handling these things.  You can see this by creating an empty 
folder in your Start Menu and then opening it up.

I'm seeing this also in the Back drop-down menu today, because there seems to be 
a bug where items aren't getting added to that menu.  So this is definitely an 
overall menu problem.

Comment 1

19 years ago
This is 33723, whose summary I'm about to update...

*** This bug has been marked as a duplicate of 33723 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
Verified dupe of bug 33723: "Need to display empty menus differently (currently
display as tiny boxes)"
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.